locked
System.ServiceModel.Web --- ERROR: doesn't contain any public member or cannot be found. RRS feed

  • Question

  • In my Ajax WCF service  the System.ServiceModel.Web import shows error:" Namespace or Type specified in the  Imports  System.ServiceModel.Web does contain any public member or cannot be found. Make sure the namespace or type is defined and contains at least one public member. Make sure the imported element doesn't  use any aliases."

    I have tried referencing the System.ServiceModel.Web.dll in several locations. It will show referenced, but the service doesn't reflect it. 

    The target framework is 4.0

    thanks

    mark



    Wednesday, April 29, 2015 3:37 PM

Answers

  • I found my mistake..  I needed to enter the target framework after the compilation debug in web.config

    <compilation debug="true" targetFramework="4.0">

    sheesh

    • Marked as answer by deeredealer Wednesday, April 29, 2015 3:54 PM
    Wednesday, April 29, 2015 3:54 PM

All replies

  • I found my mistake..  I needed to enter the target framework after the compilation debug in web.config

    <compilation debug="true" targetFramework="4.0">

    sheesh

    • Marked as answer by deeredealer Wednesday, April 29, 2015 3:54 PM
    Wednesday, April 29, 2015 3:54 PM
  • Hello,

    I'm glad to hear that you got it working. and thank you for sharing your solutions & experience here. It will be very beneficial for other community members who have similar questions.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, April 30, 2015 1:37 AM
    Moderator