locked
How do I update my WITs from v1.4 to 2.0 or from VS2008 to VS2010? RRS feed

  • Question

  • We've upgraded from VS/TFS2008 to 2010 and I'm running into some problems.  In this one, I can't edit my WIT because of the version.

    Using the Power Tools Process Editor, I go to the Work Item Tracking tab and right click my WIT 'bug' and click edit.  Then I get an error:

    Error 1 Unsupported version '1.4.0.0', can only support '2.0.0.0'. C:\...\WorkItem Tracking\TypeDefinitions\Bug.wit 2 2 Miscellaneous Files

    The line from the xml file:

    <workItemType dslVersion="1.4.0.0" Name="Bug" source="C:\...\WorkItem Tracking\TypeDefinitions\Bug.xml" xmlns="http://schemas.microsoft.com/dsltools/WITDesigner">
     

    How do I upgrade the version so I can edit the WIT?  I've also tried importing wits from other projects, and they get the same error too.

     

    Thanks

    Wednesday, August 18, 2010 8:56 PM

Answers

  • I may have just fixed this.  I deleted the wit and diagram files, opened the sml file and changed the version manually and now it lets me open it up in the wit editor.  I guess the issue was more with the wit or diagram file.  I also noticed that once I reopened the wit, the dslVersion seems to have been removed from the xml file.

    So it appears to be fixed now.  You'd think I would have thought about doing this before I logged this issue.  But then the error message wasn't obvious either.  At least this is now logged for someone else's researching pleasure.  I hope it helps you out.

    Thursday, August 19, 2010 2:53 PM

All replies

  • I may have just fixed this.  I deleted the wit and diagram files, opened the sml file and changed the version manually and now it lets me open it up in the wit editor.  I guess the issue was more with the wit or diagram file.  I also noticed that once I reopened the wit, the dslVersion seems to have been removed from the xml file.

    So it appears to be fixed now.  You'd think I would have thought about doing this before I logged this issue.  But then the error message wasn't obvious either.  At least this is now logged for someone else's researching pleasure.  I hope it helps you out.

    Thursday, August 19, 2010 2:53 PM
  • Hi johnsonr529,

    Thanks for sharing your solution, which will be helpful to other community members having the similar issue.

    Best Regards,

    Cathy Kong

     

    • Proposed as answer by MIDawood Tuesday, February 11, 2014 7:11 PM
    Monday, August 23, 2010 9:43 AM
    Moderator
  • Are the Wit and Diagram files needed? After I delete them I don't see them come back. But removing them DID resolve the error as you mentioned.
    Friday, February 18, 2011 8:37 PM