Add my Library to Device GAC deosn't work, help!


  • Hi everyone,


    I have been reading all the possible blogs and MSDN articles...

    I have been trying to add my dll under the device GAC without success.

    1) My dll is signed ->MyLibrary.dll

    2) I copy my dll under the device windows directory

    3) I have a file called InstallMyLibrary.GAC that contains one line -> \Windows\MyLibrary.dll

    4) I copy this file under the windows directory


    As said in the articles "The next time you run a managed application, your dll will by added to the GAC...".

    This is not happening!?

    My dll is still under the Windows directory, it is not transformed into GAC_MyLibray.dll.


    I'm also going this under the emulator. I have not yet try under the real device.


    What could be wrong? What Am I missing here? Any recommended readings?


    Thanks for your time.



    Thursday, May 10, 2007 3:59 AM


  • I think I found it.



    I was using a GAC file generated by a Visual Studio CAB project.


    I tried what Peter is describing.

    1) I have created a txt file using notepad.

    2) Added the line about my assembly.

    3) Renamed the file MyAssembly.GAC

    4) Copied the file on the device under \Windows directory

    5) Run a .Net App


    It worked, this time my Assembly was intalled under the device GAC.


    So it seems to be a Visual Stusio bug. Hope it will be fixed in Orcas.



    Thursday, May 10, 2007 5:53 AM