locked
Giving error While Editing and Saving the Word, Excel on SharePoint Document Library? RRS feed

  • Question

  • When tried to edit the docuement from document library and try to save it throws and error "The internet address http://server name/Sharedocument/-----.xlsx i s not valid. I am worderning that it is working till yesterday afternonn. Sunddenly it start giving this issue from yesterday noon. Also shocking is that it allows to update on other site collections it is showing error only on the root site colllection. I would be very thankful if anyone can help me to solve issue ASAP.

    Thanks in Advance.

    sa24

    Tuesday, June 18, 2013 11:57 PM

Answers

  • Hi sa24,

    please try to open the web.config and set the custom error mode to remote only, as directed, and we may see the issue there,

    and then please have a check your ULS log for more clues, you can search based on the time of the incident.

    from what the page shows, this error code most likely at your IIS level. perhaps there was a time out or the site collection is in lock mode, or the space for the site is already full/exceeded from the settings, and also perhaps your web application is not active in IIS.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by sa24 Friday, June 21, 2013 6:27 PM
    Friday, June 21, 2013 8:18 AM
  • Thank you Aries,

    By changing the CustomError Mode  to 'ON'. Then only i am enable to find the correlation id. By checkin the with that correlation id in the USLog.

    I found that Remote Blob Storeage was enable. By Disabling the Blob Storage Setting, it start working

    I* diable setting using following powershell command.

    $cdb = Get-SPContentDatabase WSS_Content

    $rbss = $cdb.RemoteBlobStorageSettings

    $rbss.Disable()

    • Marked as answer by sa24 Friday, March 11, 2016 6:04 PM
    Friday, June 21, 2013 6:36 PM

All replies

  • Hi sa24,

    Could you please check if any of the following symbols within the URL address or file name? If the URL contains the following symbols, it will come across the “The internet address is not valid” error when saving the document. (KB905231)

    ~ # % & * {} \ : <> ? / + | ‘’

    If this is not your problem, if the problem occurs on certain web application, check if AAM configurated correctly. If this problem does not reproduce on the other sites in the same web application, please check if there is any error in ULS log.

    Thanks & Regards,
    Emir Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please click here.


    Emir Liu
    TechNet Community Support

    Thursday, June 20, 2013 6:12 AM
  • Thank you for reponse.

    our file name does not have any kind of above mentioned symbols and i checked AAM, it is working fine. Ther is nothing in the ULS log too. I am getting error only on one sitecollection. The issue is still ano it is occuring only on one site collection. Evn i tried to create new document library and when tried to upload the file in document library i got below error. 

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

    It is not allowing me to upload and edit any kind document under the root site collection.

    Thursday, June 20, 2013 5:06 PM
  • Hi sa24,

    please try to open the web.config and set the custom error mode to remote only, as directed, and we may see the issue there,

    and then please have a check your ULS log for more clues, you can search based on the time of the incident.

    from what the page shows, this error code most likely at your IIS level. perhaps there was a time out or the site collection is in lock mode, or the space for the site is already full/exceeded from the settings, and also perhaps your web application is not active in IIS.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by sa24 Friday, June 21, 2013 6:27 PM
    Friday, June 21, 2013 8:18 AM
  • Thank you Aries,

    By changing the CustomError Mode  to 'ON'. Then only i am enable to find the correlation id. By checkin the with that correlation id in the USLog.

    I found that Remote Blob Storeage was enable. By Disabling the Blob Storage Setting, it start working

    I* diable setting using following powershell command.

    $cdb = Get-SPContentDatabase WSS_Content

    $rbss = $cdb.RemoteBlobStorageSettings

    $rbss.Disable()

    • Marked as answer by sa24 Friday, March 11, 2016 6:04 PM
    Friday, June 21, 2013 6:36 PM