none
Deployment problem in biztalk application RRS feed

  • Question

  • i am deploying my biztal server project after deployement of my project i am getting below error, i restarted visual studio as administrator also,host is in running mode, snk is also provided ,kindly tell me how to solve ,thanks in advance

     

    Error    1    Unable to deploy early bindings.        0    0

     

    Error    2    at Microsoft.BizTalk.Deployment.Assembly.BtsAssembly.DeployEarlyBinding(String applicationName)
       at Microsoft.BizTalk.Deployment.Assembly.BtsAssembly.Save(String applicationName)
       at Microsoft.BizTalk.Deployment.BizTalkAssembly.PrivateDeploy(String server, String database, String assemblyPathname, String applicationName)
       at Microsoft.BizTalk.Deployment.BizTalkAssembly.Deploy(Boolean redeploy, String server, String database, String assemblyPathname, String group, String applicationName, ApplicationLog log)        0    0

     

    Error    3    Unable to deploy early bindings.
    Failed to update binding information.
    Could not store transport type data for Primary Transport of Send Port 'BizTalk Server Project3_1.0.0.0_BizTalk_Server_Project3.BizTalk_Orchestration1_Port_2_f8f05fbc866851f0' to config store. Primary SSO Server 'WIN7-PC' failed. Cannot perform encryption or decryption because the secret is not available from the master secret server. See the event log (on computer 'WIN7-PC') for related errors.        0    0

    Error    4    Failed to add resource(s). Change requests failed for some resources. BizTalkAssemblyResourceManager failed to complete end type change request. Unable to deploy early bindings. Failed to update binding information. Could not store transport type data for Primary Transport of Send Port 'BizTalk Server Project3_1.0.0.0_BizTalk_Server_Project3.BizTalk_Orchestration1_Port_2_f8f05fbc866851f0' to config store. Primary SSO Server 'WIN7-PC' failed. Cannot perform encryption or decryption because the secret is not available from the master secret server. See the event log (on computer 'WIN7-PC') for related errors.        0    0   
    Thursday, September 16, 2010 3:05 AM

Answers

  • SSO has a secret key that it uses to encrypt/decrypt values in the SSO DB which includes all of the port configuration values. When you configure SSO Service from the Configuration wizard you store a file with this key as a password on disk. You will need this file in order for the SSO to work. If you have moved or lost this file you would need it back in order to get SSO working. Also see this thread http://social.msdn.microsoft.com/Forums/en/biztalkgeneral/thread/7cf95a34-2ea5-4335-b6b2-a986d3726754

    To restore the key see How to Restore the Master Secret  

    The error can also occur if someone has changed the password of the SSO service account. For this you can find a solution here. http://www.cnblogs.com/rickie/archive/2006/12/14/592391.html


    Abdul Rafay - MVP & MCTS BizTalk Server
    blog: http://abdulrafaysbiztalk.wordpress.com/
    Please mark this as answer if it helps.
    Thursday, September 16, 2010 5:56 AM
  • Hi,

    This error means that the deployment API is not able to store information in the SSODB because the ENTSSO service (named 'master secret server' in your case) is not running or not correctly setup.

    Start the ENTSSO service and check the eventlog to see if you have any error about it.

     

     


    David GROSPELIER NOVELI MVP BizTalk 2010 dgr@noveli.fr blog.noveli.fr
    Thursday, September 16, 2010 4:39 AM

All replies

  • Hi,

    This error means that the deployment API is not able to store information in the SSODB because the ENTSSO service (named 'master secret server' in your case) is not running or not correctly setup.

    Start the ENTSSO service and check the eventlog to see if you have any error about it.

     

     


    David GROSPELIER NOVELI MVP BizTalk 2010 dgr@noveli.fr blog.noveli.fr
    Thursday, September 16, 2010 4:39 AM
  • SSO has a secret key that it uses to encrypt/decrypt values in the SSO DB which includes all of the port configuration values. When you configure SSO Service from the Configuration wizard you store a file with this key as a password on disk. You will need this file in order for the SSO to work. If you have moved or lost this file you would need it back in order to get SSO working. Also see this thread http://social.msdn.microsoft.com/Forums/en/biztalkgeneral/thread/7cf95a34-2ea5-4335-b6b2-a986d3726754

    To restore the key see How to Restore the Master Secret  

    The error can also occur if someone has changed the password of the SSO service account. For this you can find a solution here. http://www.cnblogs.com/rickie/archive/2006/12/14/592391.html


    Abdul Rafay - MVP & MCTS BizTalk Server
    blog: http://abdulrafaysbiztalk.wordpress.com/
    Please mark this as answer if it helps.
    Thursday, September 16, 2010 5:56 AM
  • Hi I got it.

    The issue is because of we didn't specify the file name in the early binding.

    For Example :

    If we configure early binding(Specify now) that means in the logical port for file adaptor,we need to give the full path like  

    E:\Sathya\ExceptionHandling\test\out\filename.xml

    and also check the physical ports were deleted before you deploy the project.

    Thanks & Regards,

    SathyaPrakash.S


    Thursday, March 20, 2014 7:18 AM