locked
AT&T Broadband does not show up any more. RRS feed

  • Question

  • I have sucessfully enroled and used the service but now it is no longer showing up as an option in wireless. I have tried disabling and reenabling broadband, but still no luck. Any sugestions short of refreshing?
    Thanks Noel
    Tuesday, September 20, 2011 5:01 AM

Answers

  • We have identified one issue that can occur if the system refresh feature is used that causes this failure. If you have refreshed the system and lost your adapter in the UI you can resolve this in one of two ways:
    1. System Restore
    2. Delete the keys under “HKEY_LOCAL_MACHINE\Software\Microsoft\Wwansvc\Profiles”
    If you delete the keys, the next time you attempt to connect to the AT&T network you will be presented with an APN selection dialog. If you have activated your account, you will want to chose the "broadband" APN.
    That you all for helping root cause this issue and we are working on addressing this issue.
    Thanks,
    -Tripp
    Thursday, September 29, 2011 11:48 PM
  • Here's a workaround.

    In the command prompt first run:

               netsh mbn sh pro i=*

    You should see some devices listed. Pick one of them and run this command

               netsh mbn connect i=* connmode=name name=INTERFACENAME

    where INTERFACENAME is one of the entries from the list. See if you have a connection. If not, try again with another one. For my it was the GUID that ended with {xxxxx}.internet that did the trick for me.

    To disconnect, go to adapter settings and hit "disable" on the broadband model (not pretty, but it will get you going for now).

    I didn't figure this out. All the Kudos goes to Tripp

    Thursday, September 22, 2011 10:56 PM

All replies

  • Can you send the output from

    netsh mbn sh interface

     

    Thanks,

    Tripp

    Tuesday, September 20, 2011 6:01 AM

  • There is 1 interface on the system:

        Name               : Mobile broadband
        Description        : GlobeTrotter MO67xx - Network Interface
        GUID               : {4669C755-259F-458B-BB74-C0F6F5B54EAC}
        Physical Address   : 00:00:00:00:00:00
        State              : Not connected
        Device type        : Mobile Broadband device is embedded in the system
        Cellular class     : GSM
        Device Id          : 354153040062829
        Manufacturer       : Option N.V.
        Model              : GTM661W
        Firmware Version   : 1.8.1.0
        Provider Name      : AT&T
        Roaming            : Not roaming
        Signal             : 41%

     


    Thanks Noel
    Wednesday, September 21, 2011 2:46 AM
  • I am experiencing the same problem.  I no longer see AT&T Mobile Broadband in my list of wireless networks.  I ran the command you suggested above and got the same output as Noel...  Any ideas?
    Wednesday, September 21, 2011 7:02 PM
  • Me too. Also see this thread: http://social.msdn.microsoft.com/Forums/en-US/windowsdeveloperpreviewgeneral/thread/e3ff084a-79aa-46bf-8d63-ad5143b2701d

    I'm getting:

    C:\windows\system32>netsh mbn sh interface

    There is 1 interface on the system:

        Name               : Mobile broadband
        Description        : GlobeTrotter MO67xx - Network Interface
        GUID               : {F99EB829-D540-4933-90EE-E5034BB3697E}
        Physical Address   : 00:00:00:00:00:00
        State              : Not connected
        Device type        : Mobile Broadband device is embedded in the system
        Cellular class     : GSM
        Device Id          : 354153040074154
        Manufacturer       : Option N.V.
        Model              : GTM661W
        Firmware Version   : 1.8.1.0
        Provider Name      : AT&T
        Roaming            : Not roaming
        Signal             : 16%

     

    Also from C# if I call "Windows.Networking.NetworkOperators.MobileBroadbandAccount.GetAllNetworkAccountIds()" I get an empty list returned.


    Wednesday, September 21, 2011 7:52 PM
  • Thank you for your reply. I'm currently determining what tracing will be useful to help pinpoint the cause of this failure.

     

    Tripp

     

    Wednesday, September 21, 2011 9:18 PM
  • Can you run the following commands from an elevated command prompt


    Netsh trace start wwan_dbg,nid_wpp persist=yes
    shutdown /s /full
     <power on the machine>
    netsh mbn sh interface
    netsh mbn sh ready i=*
    netsh trace stop

    This will generate an .etl and a cab file (located in the same directory as the etl) with information about your machine.
    If you could share the cab with me  that would help pinpoint the issue and hopefully give us enough information to find a workaround.


    Thanks for your help,

    Tripp

     

    Wednesday, September 21, 2011 9:53 PM
  • How do I send / upload the cab file?
    Thanks Noel
    Thursday, September 22, 2011 12:21 AM
  • Could you email it to me at tparks @ microsoft?

    Thursday, September 22, 2011 4:05 AM
  • I have the same problem. I did a refresh to solve a keyboard issue and the 3G is no longer showing up. The AT&T app shows a dbg UI with a drop box stating "AT&T (inactive) [Device not available]".

    The 3G doesn't appear in the Networks sidebar, mobile broadband is enabled in Control Panel->Wireless, under the classic Control Panel the Windows Network Diagnostics states "This computer is set to manually connect to AT&T. To automatically connect to this network, you need to change the autoconnect settings for this network."

    My 'netsh mbn sh interface' is the same as others except for the device ID && signal%

    Thursday, September 22, 2011 5:57 PM
  • Here's a workaround.

    In the command prompt first run:

               netsh mbn sh pro i=*

    You should see some devices listed. Pick one of them and run this command

               netsh mbn connect i=* connmode=name name=INTERFACENAME

    where INTERFACENAME is one of the entries from the list. See if you have a connection. If not, try again with another one. For my it was the GUID that ended with {xxxxx}.internet that did the trick for me.

    To disconnect, go to adapter settings and hit "disable" on the broadband model (not pretty, but it will get you going for now).

    I didn't figure this out. All the Kudos goes to Tripp

    Thursday, September 22, 2011 10:56 PM
  • The workaround works for me using the internet entry. Thanks!
    Friday, September 23, 2011 2:02 AM
  • This worked for me, in that I was able to connect using my mobile broadband connection... however, it still does not show up in my list of available networks (via the wireless network settings), whereas all of my wifi connections are showing up.  Is it supposed to?
    Friday, September 23, 2011 12:39 PM
  • Mobile broadband should show up in the list of available networks. We are investigating why the connection has disappeared from the list of available networks.

    Tripp

    Friday, September 23, 2011 8:59 PM
  • I too, am unable to get mobile broadband to show up, even after doing a refresh and applying the above mentioned workaround. More help would be appreciated. Thanks!

    - Homi

    Saturday, September 24, 2011 11:53 PM
  • the above workaround does not make the connection show up. It only makes it connect to it.
    Sunday, September 25, 2011 12:59 AM
  • So I have not responded for a few days because for me doing a refresh, has fixed my issues, at least until I need to do a Hard Shut down (Holding power button down until it shuts down). Do you still need the output of the commands listed above?

     


    Thanks Noel
    Wednesday, September 28, 2011 7:56 AM
  • N Anderton: The refresh resolved the issue of the device not showing up? Did it occur again on hard shutdown?

     

    If so, the logs running post reset, then hard shutdown would be helpful.

    Wednesday, September 28, 2011 11:20 PM
  • We have identified one issue that can occur if the system refresh feature is used that causes this failure. If you have refreshed the system and lost your adapter in the UI you can resolve this in one of two ways:
    1. System Restore
    2. Delete the keys under “HKEY_LOCAL_MACHINE\Software\Microsoft\Wwansvc\Profiles”
    If you delete the keys, the next time you attempt to connect to the AT&T network you will be presented with an APN selection dialog. If you have activated your account, you will want to chose the "broadband" APN.
    That you all for helping root cause this issue and we are working on addressing this issue.
    Thanks,
    -Tripp
    Thursday, September 29, 2011 11:48 PM
  • System reset gave me back the icon. Thank Tripp!

    However, on trying to sign up I cannot get past the 'DataConnect Pass' which prompts for 'Device Nickname' and 'Where was the device purchased'. On hitting 'Save', I end up on a 'Login' page (for existing customers)....essentially going around in circles. 

    Anyone else having the same issue and knows how to get around this?

     

    Friday, September 30, 2011 7:08 AM
  • Can you try again now. It sounds looks the activation service was having issues.

    Thanks,

    Tripp

    Friday, September 30, 2011 5:35 PM
  • I just did and the behavior is still the same. For some reason, it thinks I am an existing customer and keeps redirecting me to the login page.

    Earlier, before I performed the reset (and subsequent refresh), I did get to the final completion page but never did make it to full activation - something failed. I am wondering if the remnants of this is lodged in the sim itself. I did try logging in with my email and pw too, but that fails too.

    Feels a lot like limbo, neither here nor there
    J

    Friday, September 30, 2011 6:35 PM
  • Unfortunately it sounds like you will need to contact AT&T customer support. IT sounds like the account is in a half setup state.

    Tripp

    Tuesday, October 4, 2011 8:37 PM
  • Tripp,

    Good advice.

    As suspected my account was partially set up. After identifying my sim # to customer support, I could get my user name and password reset and was successful in using the DataConnect pass on the att web site to set up the account.

    ATT customer support was very patient and helpful. :)

    Thanks,

    Homi

    Tuesday, October 4, 2011 9:35 PM
  • After doing a reset of the Samsung the AT&T Mobile Broadband network appeared in the network sidebar again. It shows connected and connects to the internet. However the AT&T Mobile Broadband App gives this Error when startup up: You need an AT&T SIM card to use this application. Obviously the SIM card is in and working.
    Peter Bowers
    Wednesday, October 5, 2011 1:53 PM
  • So to clarify where I am at. the Hard shutdown does appear to make my AT&T connection dissapear, as do any other crashes that I suffer. Reseting my Slate fixes it (properly) the work around from Morten above restores the connection but does not fix the whole problem.

    I dont beleive i have any issues with AT&T, unlike some of the others on the thread. Still hoping for a permanent fix.


    Thanks Noel
    Friday, October 7, 2011 9:01 PM
  • After restoring the device the AT&T connection reappeared and was working correctly. Two updates were applied, after applying KB2608612 and restarting, the AT&T service was still there and working. After applying KB2614194 and restarting the AT&T connection disappeared. Doing a system restore to a point just prior to installing the second update did not re-enable the AT&T connection.


    Peter Bowers
    Monday, October 10, 2011 2:03 PM
  • Any update on this at all? it appears I have to run the NETSH command after each reboot. Is that correct?

     

    Wednesday, October 12, 2011 5:07 PM
  • System Restore used to work, but now one of the KB patches that is auto-updates breaks it again.

    Tried to do the regedit "Run As Administrator" and it gives error on trying to delete the keys.

    Any other ideas/fixes?

    Monday, October 17, 2011 6:03 PM
  • In the command prompt first run:

               netsh mbn sh pro i=*

    I also have a problem with the missing AT&T Broadband. I tried running this command, and this is what I got:

         Mobile Broadband Service (wwansvc) is not running.

    I tried to run this service from the Computer Management, but got this message:

         Windows could not start th WWAN AutoConfig service on Local Computer.

         Error 5: Access is denied.

    I tried to run this command

         svchost.exe -k LocalServiceNoNetwork

    at the command prompt (also at the command prompt started As Administrator), but nothing happens. No error, either. It just takes the command and pretends that it succeeds.

    Wednesday, October 19, 2011 12:15 AM
  • I was getting the errors saying that it couldn't delete the keys under HKEY_LOCAL_MACHINE\Software\Microsoft\Wwansvc\Profiles. I finally was able to delete them by going on each key, editing the permissions, changing the ownership to administrators, changing the everyone permission to full control, and then deleting them. If you just give yourself or the administrators group permission it still gives you the error. Doesn't make any sense but that's what worked for me. Once I did that, the AT&T connection showed up and I was able to select the broadband access point. Yay!
    Wednesday, December 14, 2011 7:09 PM