locked
SketchFlow Styles in Blend 3 RRS feed

  • Question

  • Hi,

    I am using Blend 3 + SketchFlow RC which was made available yesterday. I see few blogs showing some pencil like sketches, In that they shown that those controls are available in Asset Library e.g ListBox-Sketch or Note-Sketch etc. which can be drap drop.

    I am not able to locate those controls-sketch, so want to know, do I need to develope it or they are built-in? if so, what are ways to do so?

    Thanks,

    Vikram.
    Saturday, July 11, 2009 4:14 AM

Answers

  • The following worked for me (installing on Win 7 RC)

    • Used uninsall programs to remove all Silverlight programs etc. version 3 and before
    • Removed Visual Studio tools for Silverlight 3
    • Removed Visual Web Designer Tools for Silverlight 3 (or something like that)
    • Uninstalled Blend 3 with Sketchflow
    • Reninstalled Blend 3 with Sketchflow unsing compatability settings for Vista SP2
    Not sure if the compatability settings made any difference, but when I reinstalled Blend I had the Sketchflow styles installed.

    Hope this works for others

    Mark
    Saturday, July 11, 2009 2:50 PM

All replies

  • Hey Vikram,
                        These sketch styles are available in Sketchflow projects. If you open the New Project Dialog and create a WPF / Silverlight Sketchflow project then you should be able to see skecth styles in Asset Lib.

    HTH.

    Regards,
    Navit Saxena

    Saturday, July 11, 2009 5:16 AM
  • Hello Navit,

    Actually I followed the same steps still I am not able to view so, is there any way I can pass on the screenshot. I assume to get that under SketchFlow->Styles in Asset Tabs, but it shows nothing and only message, "This category shows the styles that are available to for use in your SketchFlow Project", am I missing some dll? even when I build that prj it gives me error as "Could not resolve assembly MS.Expression.Prototyping.SketchControls" ..do I need to uninstall it reinstall again..is there any other solution ?

    Thanks,

    Vikram.
    Saturday, July 11, 2009 9:20 AM
  • Hi

    I have the exact same problem. Any suggeestions would be great

    Mark
    Saturday, July 11, 2009 12:00 PM
  • The following worked for me (installing on Win 7 RC)

    • Used uninsall programs to remove all Silverlight programs etc. version 3 and before
    • Removed Visual Studio tools for Silverlight 3
    • Removed Visual Web Designer Tools for Silverlight 3 (or something like that)
    • Uninstalled Blend 3 with Sketchflow
    • Reninstalled Blend 3 with Sketchflow unsing compatability settings for Vista SP2
    Not sure if the compatability settings made any difference, but when I reinstalled Blend I had the Sketchflow styles installed.

    Hope this works for others

    Mark
    Saturday, July 11, 2009 2:50 PM
  • Hey Vikram,

    The error you are getting for the SketchControl.dll suggests that Blend SDK installation is messed up. I would suggest you to uninstall Blend + Blend SDK + SL SDK  and reinstall them and check if that solves your problem. If still you are not able to see the sketch styles, please send your project and installation details (machine, OS) to navits at microsoft dot com and we will take a look.

    Thanks,
    Navit Saxena

                  

    Saturday, July 11, 2009 5:26 PM
  • Hi,

    I am using Blend 3 + SketchFlow RC which was made available yesterday. I see few blogs showing some pencil like sketches, In that they shown that those controls are available in Asset Library e.g ListBox-Sketch or Note-Sketch etc. which can be drap drop.

    I am not able to locate those controls-sketch, so want to know, do I need to develope it or they are built-in? if so, what are ways to do so?

    Thanks,

    Vikram.

        Go to File -> New Project   Select Sketch flow under silverlight/wpf

       if you have selected silverlight then Select "Silverlight 3 SketchFlow Application "
      
       select the appropriate language c# or vb.net and click on Ok
      
       go to Resource Tab (if not found select from Window->Resources)
     
       There you will find SketchStyles.xaml
     
       Just expand that you will find controls-sketch (like Button-Sketch, Listbox-Sketch)  just drag and drop it on art board you will find pencil like sketches....

    I hope this will help you :)



    Prasad - www.beautifulmind.blog.co.in
    Microsoft MVP
    • Proposed as answer by prasad22 Saturday, July 11, 2009 6:30 PM
    Saturday, July 11, 2009 6:30 PM
  • Another option to use sketch styles in a sketchflow application is to set the sketch styles as the default style. This means that when you create a new control (from the toolbar, or when using drag drop from the data pane) you will get by default a control which uses the sketch style. Here is how to do that:

    In the asset library (the ">" button underneath the toolbar), in the category tree (left side tree) right click on the node "Styles/SketchStyles". This will display a context menu which gives you the option "Set As Default Style". From this point, if you create say a button from the toolbar, you will get one with the sketch style.

    Thanks,
    Adrian
    Saturday, July 11, 2009 7:44 PM
  • Mark and Navit

    I reinstalled it and now its working very well, Thanks for your help !, I guess as Navit said, must be some problem with my installation.

    Prasad and Adrian

    Thanks for your support !

    Regards,

    Vikram.
    Sunday, July 12, 2009 2:59 AM
  • Hi,

    I installed the Blend + Sketchflow the day after it was released and had the same problem. So I uninstalled & downloaded it again today (July 22nd) and the sketch style is now in place.

    Øyvind
    Wednesday, July 22, 2009 9:48 AM
  • There was a known bug in the installer if you had the MIX preview installed, and then installed the RC of Blend 3.  There were 2 important registry keys that would not get set properly.  Simple solution is to uninstall the Blend sdk and Blend 3, and reinstall.  Otherwise, you could add the relevant keys to the registry yourself.

    Here is more info:

    You probably have two missing registry keys: (Note, these are for 64 bit machines, if you are in 32 bit, omit the Wow6432Node)

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Microsoft SDKs\Silverlight\v3.0\AssemblyFoldersEx\Expression SketchFlow

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Microsoft SDKs\Silverlight\v3.0\AssemblyFoldersEx\Expression Blend

    If you enter the location of the Blend SDK there, then you should be up and running.

    For the first registry path above, add a (Default) REG_SZ with Data:
    C:\Program Files\Microsoft SDKs\Expression\Blend 3\Interactivity\Libraries\Silverlight\

    For the second path above, add a (Default) REG_SZ with Data:
    C:\Program Files\Microsoft SDKs\Expression\Blend 3\Prototyping\Libraries\Silverlight\

    • Proposed as answer by JodeAllen Thursday, March 18, 2010 3:12 PM
    Wednesday, July 22, 2009 12:22 PM
    Moderator
  • I'm assuming I'm experiencing the same problem.  When I start a Silverlight SketchFlow app I'm missing the dlls that are required to load the the sketchy styles. The sketchy style resource dictionary is not being merged in the app.xaml and the associated reference assemblies are not being resolved. I was using an installation of Blend 3 v3.0.1927.0 and had tried uninstalling and reinstalling in various orders with no resolution.

    I found that I was indeed missing the registry keys that Chuck pointed out and everything appears to be working perfectly after I added them.

    Thanks.

    Thursday, March 18, 2010 3:17 PM