Unable to connect to wireless network


  • I am currently experimenting with different embedded templates within the IBW. I am able to use the IBW and create an image using the STB template. However, i am unable to connect to the wireless network. All of the drivers for the motherboard (onboard wifi) have been loaded and the system detects the wireless adapter. The problem is that i cannot conect the device. When i attempt to connect to a network (either in network and sharing or the adapter settings) nothing happens, i click "connect" or "connect to a network" and i get no result. Connecting via ethernet LAN works fine. I've tried this on a couple of test machines but cannot get it to work. Any advice/solutions would be greatly apreciated.
    Wednesday, July 27, 2011 12:22 PM

All replies

  • Is the Wireless Networking package in the image?

    Is the Windows Firewall package in the image?

    Have you tried building the image using ICE?


   / /, Book Author - ProGuide to WES 7, XP Embedded Advanced, WEPOS / POS for .NET Step-by-Step
    Wednesday, July 27, 2011 8:39 PM
  • Yep, both packages are apart of the image, i just wanted to do a quick test to see the stability of and embedded stb using media center. Interestingly enough, when you first load the image during installation/setup it asks you to connect to a network (and shows the avaialble networks within range). However, since in theory the user of an embedded device would never see this screen, as it happens during the installation of the imagw. You can skip it and it says you can come back (which isnt really true). After this you can no longer find or connect to a network. You can access the Network and SHaring center (either by hitting F1 or opening the task manager with ctrl+alt+del) but no action occurs when you hit "connect to network"

    I guess i will have to try with ICE
    Thursday, July 28, 2011 2:05 PM

  • Well i have tried using an image created with ICE, all drivers for the motherboard were loaded as apart of the installation and recognized. However i still cannot connect to the internet using a wireless connection. Has anyone using IBW stb template or ICE to create a media center successfully connected to a wireless network, post installation?

    • You can get to network and sharing center and see that a wireless adapter is installed, but you cannot "connect to" (nothing will happen)
    • If you select connect to  a network from the main "network and sharing center", again nothing happens. Its as if the clicks are useless
    • all preloaded wireless utilities do not work in this type of build

    If anyone can help me with this I would be greatly appreciative

    Thursday, August 04, 2011 2:29 PM
  • Did you ever progress with this issue? I suspect it to be a general Windows Embedded 7 issue as we are experiencing the same problem when using the custom shell package.

    If we use the explorer shell (default) then it appears to work.

    Tuesday, October 25, 2011 1:08 PM
  • Hi,

    I'm also working on this similar issue. It seems that if we use a custom shell without explorer running, we will not be able to get the Connect/Disconnect window at bottom right to appear because simply, no explorer is running.

    I thought of this and may have to dump the idea of NOT running explorer.exe. But, if without explorer shell running, and we can get to

    Control Panel\Network and Internet\Manage Wireless Networks

    Maybe we have a chance...

    Edit: That's not the solution either....sigh.
    • Edited by lyk13 Tuesday, November 01, 2011 11:00 AM
    Tuesday, November 01, 2011 10:47 AM
  • Thursday, November 10, 2011 7:25 PM