none
Rediscovery unsuccessful despite assigning service user DB login RRS feed

  • Question

  • I want to backup my SQL Server DB with Azure Recovery Services. I'm creating a backup with type "SQL Server in Azure VM (Preview)" and check the respective VMs for discovery. As expected, the "UserErrorSQLNoSysadminMembership" error occurs, because the SQL Server DB is installed manually after VM deployment, so it's not a preconfigured Azure SQL Server VM, but a Windows VM with SQL Server installation.

    After discovering the VMs with Windows 2016 and SQL Server 2014/2016, I added DB login for "NT SERVICE\AzureWLBackupPluginSvc" user and gave it sysadmin server role as per documentation. Then I'm running "Rediscover DBs", but I'm still getting the "UserErrorSQLNoSysadminMembership" error. I also tried with restarting all services and also restarting the VMs, same result.

    Any clue?

    Wednesday, January 16, 2019 2:23 PM

All replies

  • Hello Matt, Apologies for the delayed response. We are working internally with the Azure Backup team to get you an answer. Thanks for your patience. We will provide an update soon.

    Thursday, January 24, 2019 1:39 AM
    Moderator
  • Hello. Is there any update on this?
    Thursday, March 14, 2019 2:27 PM
  • Sorry for the delay, Matt. We are Looking into this. In the meantime, please send a mail to AzCommunity@microsoft.com and include your subscription ID and a link to this MSDN thread (for context)

    This will help us communicate effectively just in case we require additional information/data that may not be suitable to share over public forum.

    Cheers.

    Thursday, March 14, 2019 11:03 PM
    Moderator
  • Do we have any answer to this question yet?

    I am facing the same problem.

    Saturday, August 31, 2019 6:24 PM
  • Have you found the solution? Please help, facing the same problem.
    Saturday, August 31, 2019 6:26 PM