locked
after change port for TCPIP PORT for default SQL Server instance (MSSQLSERVER), sql service and sql agent service did not started again RRS feed

  • General discussion

  • Hi 




    • Changed type adilahmed Thursday, December 1, 2016 8:03 AM
    • Edited by adilahmed Thursday, December 1, 2016 8:07 AM
    Thursday, April 23, 2015 8:18 PM

All replies

  •  are you sure you specified right password  when you switched the service account to domain account.

    adding it to admin group  shold not make any difference ...

    also, you can specify the TCP port in  IP ALL section in the TCP/IP protocol 

    blank out TCP dynamic Ports  column

     Tcp PORT <<Enter your port>>


    Hope it Helps!!

    Thursday, April 23, 2015 9:04 PM
  • No, if the error message says "login failure", that means login failure. That is, username and password for the service account does not match. If you have accidently selected a port number in use, that does not prevent SLQ Server from starting.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se
    Thursday, April 23, 2015 9:29 PM
  • Hi adil,

    This service account does not have the required user right "Log on as a service."

    As the error message indicates, the MOJPORTAL\spsqlservice  account doesn’t have the Log on as a Service rights.

    To fix the issue, please open the Security Setting snap in (Secpol.msc), navigate to "Local Policies" -> "User Rights Assignment" -> "Log on as a Service."  Right-click "Log on as a Service" and select "Properties", click "Add User or Group" and add the MOJPORTAL\spsqlservice account. Then check that if you can successfully start SQL Server Service.

    Reference:
    http://collectingknowledge.blogspot.jp/2011/07/sql-server-fails-to-start-after-reboot.html

    Thanks,
    Lydia Zhang


    Lydia Zhang
    TechNet Community Support






    Monday, April 27, 2015 7:52 AM