locked
Devexpress export to pdf - RED X RRS feed

  • Question

  • Hi,

    I have an application running on windows azure.

    Because the report preview screen was always very slow and after every upgrade or something else the preview screen did not work longer I decided to export all my reports to pdf, save it in the database, download it and save it.

    This worked for me now for months, I published the application 1 month ago and the application runs on azure without andy problem. But now every report I create I only get red X instead of data and I do not know why. On my dev machine all things are okay.

    So I think that there is something wrong in the azure database, maybe one entry in the database occurs this, but I do not know where to search for this.

    Maybe someone had something similar before?

    Thanks.

    Markus

    Monday, March 25, 2013 11:22 AM

All replies

  • Hi,

    now I tried something else. I created a new project. As datasource I took my sql azure database. I added a xtrareport to my project and the code to do the export to pdf. On my dev machine this was without any problem.

    Then I published my application to azure. Hostet in azure I have the same problem again. Every report I try to open has only red x in it where the data should be.

    If the report works on the local dev machine without any problem with the same datasource as hosted in azure it seems that there is a problem with azure and xtrareport!

    Maybe someone nows if the azure team made changes in azure during the weekend?

    Thanks

    Monday, March 25, 2013 12:14 PM
  • I recently started having the same problem with one of my PDF reports on Azure that does not exist if I publish locally, which indicates to me also that the problem may lie with something Azure is doing.

    There are several forum posts on DevExpress' web site about red X errors, but none are so far pinpointing this particular problem that I have found.

    Interestingly, all other exports (Word, Excel, etc.) work without a problem.

    Even more interestingly, the PDF red-X Azure problem does not happen when a Cloud service is used to host the Lightswitch application, only Azure websites have this problem.

    I have opened a ticket with the Windows Azure technical support team and referenced this forum for add'l info.

    Monday, March 25, 2013 5:05 PM
  • Hi,

    thanks for the answer.

    What are the differences between using a cloud service or a website to host the application? Maybe I should use a cloud service...

    Curious is that I have this problem since today. Export to pdf worked fine a month without any problem.

    Markus

    Monday, March 25, 2013 5:32 PM
  • Azure cloud services have numerous additional capabilities over simple web site hosting and therefore are more expensive to subscribe to.  For my Lightswitch app, I do not need these extra capabilities so I opted not to use it.  I was also disappointed that the cloud platform still required the end-users to have the latest version of Silverlight installed on their computers, as this has sometimes been a problem on computers without administrator access that I have had to use.  I was looking for more of a thin client PaaS cloud application in Azure's cloud service but didn't find it.

    More to the point, this brings back the original frustration I have sometimes had getting report data from LS in general.  Although LS's forms over data structure is very good, LS' native reporting support is very weak in my opinion.  The "export to Excel" in data grids have numerous limitations.  For web applications, you are limited to creating ASP.net or using third-party controls like DevExpress, which is a problem because they have all potential compatibility and support issues with any LS program upgrades.  And I haven't even begun to think about how I'm going to address the reporting issue in the HTML client, which as you may know does not support the XtraReport's extension because it is specific to Silverlight only.  In my opinion, if the Microsoft LS team really wants this business product to succeed, they are going to have to improve the native reporting capabilities quite a bit.

    Monday, March 25, 2013 5:52 PM
  • Hi,

    is it also possible to host more then one lightswitch app in the same cloud service? Or do I need to subscribe one cloud sercvice per app?

    I published my app to azure as cloud service, after installing the app, I get an error, when starting the application. Cannot find Update. It is like the app pool in a IIS Server is turned off ...

    Yes, a reporting tool integrated in lightswitch would be very good. For me devexpress is very good, but upgrading devexpress xtrareport takes me always hours or days. For example I tried one day to upgrade my project from 2012 to ctp4, but with the devexpress extensions I have only problems, so I gave up with upgrading my project, because I do not want to waste more than with this.

    With the html client we can also use devexpress on server site to create reports and download it with the html client, but a integrated reporting solution would be very comfortable.

    Thanks.

    Markus


    Tuesday, March 26, 2013 2:07 AM