locked
Fullscreen MediaElement inside ContentControl Problem

    Question

  • By enlarge the size of MediaElement I can fullscreen it in a ContentControl.

    The problem is that when I source another file the background of ContentControl and the Screen will be displayed.

    So a whitebox will be saw in between. When I hide the ContentControl, the MediaElement will not be displayed as well.

    How can I solve this problem? Anyway to set the background color of an element?


    Charlie Chang L

    Friday, August 31, 2012 5:09 PM

All replies

  • Hello Charlie,

    Why are you hosting your MediaElement in a ContentControl? Typically you would not need to do this. Can you explain why you are doing this? Can you provide some sample XAML that reproduces the issue so I can take a look?

    Thanks,

    James 


    Windows Media SDK Technologies - Microsoft Developer Services - http://blogs.msdn.com/mediasdkstuff/

    Friday, August 31, 2012 9:54 PM
    Moderator
  • Yes. You are right. I removed the ContentControl. The problem is in the background of the Border element. I can not remove Border element now because I applied its background color. Anyway I can change the background color? Set to black and restore to original color later may reduce the ghost image. 


    Charlie Chang L

    Saturday, September 1, 2012 2:19 AM
  • Due to the way the ME renders the video I don't believe that you can set the background color of the ME. You can't set the opacity either.

    -James


    Windows Media SDK Technologies - Microsoft Developer Services - http://blogs.msdn.com/mediasdkstuff/

    Tuesday, September 11, 2012 12:18 AM
    Moderator