locked
Activity could not be loaded because of errors in the XAML RRS feed

  • Question



  • Hello:

    I have created a set of custom activities in Activity library, and when I test these activities in a console project, the VS gives the following error:

    Could not find type 'BPMNCustomActivities.CustomActivities.Loops.For' in assembly 'BPMNCustomActivities'.

    and the custom activity For is in that namespace

    The custom activity designer disappears and turns red with the following message:

    Activity could not be loaded because of errors in the XAML

    If anyone has any idea why this happens, please answer

    Best
    Regards



    Octavio




    Octavio Cesar

    Tuesday, May 24, 2011 2:33 PM

All replies

  • Hi Octavio,
    This means that something went wrong in the XAML deserialization of the activity step. The activity designer not showing up is meant to help make this easier to debug. (You'll also see some similar behavior for scenarios such as your XAML tries to reference properties that don't exist on the class any more.)

    Sometimes people encounter issues like this because they have an out-of-date gacced copy of the assembly. Otherwise I guess it is going to be a more straightforward type or assembly loading issue - based on missing assembly references, or similar.

    Tim

    Wednesday, May 25, 2011 5:24 PM
  • I erase the reference to the assambly and loaded again. I compiled the project and still gives me the same error. The custom activity For is in that namespace and do not see it yet.

    Best Regards

    Octavio


    Octavio Cesar
    Wednesday, May 25, 2011 7:03 PM
  • Maybe I'm missing something here. A few more questions to try to make sure

    -Are you just using standard workflow console application template code for instantiating the activity? based on new() operator? Or some other way of loading XAML?
    -What happens if you try switching to trying to do new yournamespace.For() activity in your console app - does it work OK?
    Tim
    Friday, May 27, 2011 6:04 AM
  • I got the same error and when i right click on the xaml file and select open with... then choose XML (text) edit. The problem went away. I was looking for some error in the xaml but everything works well.

    If there is error, you should get that from the xml view.

    Please check this:

    http://stackoverflow.com/questions/10553229/activity-could-not-be-loaded-because-of-errors-in-the-xaml

    Thanks,

    Bsharper

    Tuesday, January 8, 2013 4:34 PM