Error on start debugging: Could not load the Web.config configuration file RRS feed

  • Question

  • Hi,

    Just starting to use visual studio 2010 on a sharepoint 2010 (rtm) site.  Was going fine till I hit F5 to begin debugging....then I get this error...and don't see many hits when i search for it, read through the walkthroughs, don't see anything I'm missing for configurations...

    Could not load the Web.config configuration file. check the file for any malformed XML elements, and try again. The following error occurred: The given key was not present in the dictionary.

    Thanks for any and all help...

    Tuesday, January 4, 2011 9:54 AM


All replies

  • SharePoint projects don't have web.config files. You must be working on a different project type. Here's some materials that might help you out: http://msdn.microsoft.com/en-us/magazine/ee309510.aspx


    Living the SharePoint dream...
    • Marked as answer by Wayne Fan Monday, January 10, 2011 10:30 AM
    Tuesday, January 4, 2011 11:45 AM
  • Actually, the right solution is  here:

    • Proposed as answer by Senglory Thursday, November 17, 2011 10:38 AM
    Thursday, November 17, 2011 10:38 AM
  • I came across this thread and found that Senglory's answer was the one that worked with me.

    Many thanks, Senglory.

    Please, mark my reply as Answer if it helps or vote it up if it gives a key to the solution.
    Thanks in advance and good luck.
    Ahmed M. Gamil
    "It is not titles that honor men, but men that honor titles."

    Sunday, April 29, 2012 10:53 AM
  • Thanks :)
    Sunday, October 7, 2012 11:16 AM
  • Hi Senglory 

    Thank you so much this solution worked for me. I changed the project property "Site URL" correctly with my SharePoint Machine Name as it was by default taking the alternate access mapping ip.

    Thank you so much.

    Pervesh Dhingra 

    Sunday, September 24, 2017 4:02 PM