locked
Leaf Attribute imported from MDSModelImport Not Appeared to Explorer RRS feed

  • Question

  • Env: SQL Server 2012

    I'd like to import some tables into MDS entities.

    So I found MDSModelImport Program.

    Importing is worked. And I confirmed to imported columns of tables as leaf Attributes.

    I tried to insert data. But In Explorer Leaf Attributes are not shown except Code and Name.

    So I couldn't insert data. In Excel also it does.

     
    Tuesday, August 25, 2015 2:23 AM

Answers

  • I got a solution.

    In view for editing attribute, Display pixel width was 0. So I changed value greater than 0.

    It worked. 

    Thanks.

    Regards, 

    • Marked as answer by Takatoshi Nao Monday, August 31, 2015 9:48 AM
    Monday, August 31, 2015 9:48 AM

All replies

  • Hi Takatoshi,

    According to your description, you are experiencing the issue "Leaf Attribute imported from MDSModelImport Not Appeared to Explorer " when insert data to table in Master Data Services, right?

    One of the new features of MDS in SQL Server 2012 is a new process for staging data to be imported into MDS.  Key things to be aware of:

    • Each entity has its own staging table in the stg schema.
    • Each entity has its own stored procedure (udp) to load data from staging into the model.

    Leaf Members

    •  Staging table:  stg.EntityName_Leaf
    •  Stored procedure to load model:  stg.udp_EntityName_Leaf
    •  View which displays errors: stg.viw_EntityName_MemberErrorDetails

    Please refer to the link below to see the details.
    http://www.toadworld.com/platforms/sql-server/b/weblog/archive/2013/02/16/importing-data-into-master-data-services-2012-part-1

    Regards,


    Charlie Liao
    TechNet Community Support

    Thursday, August 27, 2015 6:42 AM
  • Hi, Charlie.

    Thank you for replying. 

    I confirmed Staging table and Stored procedure created.

    I will attach images later. I cannot post images because of verifying problem.

    My Step is  

    1. Execute MDSModelImport with my test database. it has one table named to testTable that has test_pk column.

    2. I can see test_pk attribute created into  testTable entity of test model on explorer tab.

    3. I would like to insert member. but In entity tab, I cannot found test_pk column except Name, Code, Last Update Date, Created Date attributes. 

    Regards, 

    Takatoshi Nao

    P.S.

    I will Attach Screenshots.

    I am sorry to My Environment language is set to japanese.

    名前(Name) コード(Code)

    In Entity Tab, testTable Entity shown only Name(名前) , Code(コード), Last Update(最終更新日時), Created Date(作成日時)


    Thursday, August 27, 2015 9:31 AM
  • I got a solution.

    In view for editing attribute, Display pixel width was 0. So I changed value greater than 0.

    It worked. 

    Thanks.

    Regards, 

    • Marked as answer by Takatoshi Nao Monday, August 31, 2015 9:48 AM
    Monday, August 31, 2015 9:48 AM