locked
SqlDataSource not showing in Visual Studio toolbox RRS feed

  • Question

  • User1145790412 posted

    Hi, the control "SqlDataSource" is not showing in my Visual Studio toolbox. Do I have to install anything to make it available? thanks

    Tuesday, November 12, 2013 9:28 AM

Answers

All replies

  • User-1716253493 posted
    SqlDataSource should exist in Data tab. Try reset the toolbox. Which version you use, and which net version your project?
    Tuesday, November 12, 2013 9:35 AM
  • User1145790412 posted

    Hi oned_gk, I did this and also selected to "choose items" in the Data tab.

    I use Visual Studio 2010 Premium, .Net Framework 3.5 and the solution is a Empty Sharepoint Project which I simply added a Visual Webpart. Inside that webpart I added a gridview and tried to bind that to the SqlDataSource.

    Tuesday, November 12, 2013 9:49 AM
  • User1145790412 posted

    well, when I clicked "choose items" I noticed the SqlDataSource already selected. If I right click the Data tab and select "Show All" I see the SqlDataSource but it is gray like disabled. Any ideas?

    Tuesday, November 12, 2013 9:54 AM
  • User-1716253493 posted
    Afaik SqlDataSource available in web form, not sure about share point
    Tuesday, November 12, 2013 10:18 AM
  • User-166373564 posted

    Hi renatois

    Net Framework 3.5 and the solution is a Empty Sharepoint Project which I simply added a Visual Webpart.

    In sharepoint projects, you cann't drag SqlDataSource from the toolbox to the visual web part,  and you have to write codes in it.

    if you want to querying data with the SqlDataSource Control (VB), you can also take a look at this article,

    # Querying Data with the SqlDataSource Control (VB) - http://www.asp.net/web-forms/tutorials/data-access/accessing-the-database-directly-from-an-aspnet-page/querying-data-with-the-sqldatasource-control-vb 

    Best regards

    Angie

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, November 26, 2013 1:07 AM