none
Visual Studio 2015 Community License Expired RRS feed

  • Question

  • Sorry that I know the question is not new...

    I have looked through many posts that have the same issue today but none of the solutions can help.

    Visual Studio said 

    "License: 30 day trial (for evaluation purposes only)

    Your evaluation period has ended"

    and then when I click "Check for an updated license"

    VS said "We could not download a license. Please check your network connection or proxy settings."

    I tried several solutions

    (1) uninstall and reinstall VS2015 community (not work)

    (I saw someone mentioned that registry keys need to be deleted, Does anyone know what keys I should delete?)

    (2) download .ISO and repair (not work)

    (3) sign in (run as administrator) (no MSDN subscription linked to my current Microsoft Account, am I suppose to purchase something?), but cannot download the license.

    but no luck so far, please help :(  

    Thanks!

    Wednesday, May 25, 2016 10:42 AM

Answers

All replies

  • Dear Debbie,

    Welcome to the MSDN forum.

    According to the error message “we could not download a license. please check your connection or proxy”, it looks like the VS cannot download a license due to the network connection or proxy settings. Please see the following steps:

    1. Check whether you’re behind a proxy server: If you're not sure, ask your administrator. If you're behind a proxy server, you may have to change the proxy settings for Windows HTTP clients.

    2. Check whether you're behind a firewall: please disable the firewall, or configure firewall to enable access the common Microsoft websites.

    3. Update IE to IE11 and set IE 11 as default browser, then clean up the history data

    4. Create a new Microsoft account to sign in: please navigate to https://account.microsoft.com/about and create a new account then use it to sign in VS, if this issue still occurs, that means it not related with the account.

    5. Please run the VS with the safe mode, and see if this issue happen or not. Please open an administrative CMD window and navigate to C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE and run these commands: devenv.exe /safemode

    6. Since many users meet the similar issue, maybe the related server was temporarily unavailable, please waiting for a monument and try to sign in and update the license later, sorry for this inconvenient.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, May 26, 2016 8:12 AM
    Moderator
  • Thank you for your reply. I solved the problem. 

    It is not about network connection or proxy settings (because I tried for whole day)

    The solution is that I have to sign in using IE instead of Microsoft Edge (I am using Win10 and thought it is IE, their icon look similar).

    Thanks.

    Friday, May 27, 2016 2:11 PM
  • Dear Debbie,

    I’m so glad to hear that your issue is solved and thank you for your sharing.

    BTW, if you think your reply is helpful, please mark your reply as the answer, it will benefit to other community members who have the same issue. It will be easier for them to search the solution.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 30, 2016 1:15 AM
    Moderator
  • I found this thread and  found someone had the same problem. but, My problem is not related to Microsoft edge.

    I am using Windows 8.1 so there is no "Microsoft Edge".

    Then What is my problem?

    p.s. I could not run Visual studio in safe mode. I might try.

    Monday, June 20, 2016 11:13 AM
  • Dear hjroh,

    There have some reasons can lead to the same issue behavior, and since your issue is not totally same with Debbie, I recommend you open a new thread for your issue and it will also convenient for us to analysis and trace your issue.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. <br/> Click <a href="http://support.microsoft.com/common/survey.aspx?showpage=1&scid=sw%3Ben%3B3559&theme=tech"> HERE</a> to participate the survey.

    Tuesday, June 21, 2016 7:29 AM
    Moderator
  • Hi there,

    I am currently experiencing the same problem. VS Community tells me my license has expired and it is unable to download a new one.

    I have tried until now:

    reinstalling VS 2015 Community TWICE

    signed out and in on all websites and browsers (IE 11 / Edge / Chrome)

    running devenv.exe in safe mode >>> it freezes the app and then closes.

    There are plenty of threads on this issue, many answers copy/pasted but none actually works.

    Support from Microsoft is virtually non-existent

    Is it worth the trouble to make it run anyway?

    Monday, October 3, 2016 6:07 PM
  • Hi cStreja,

    Welcome to the MSDN forum and sorry for this inconvenient.

    Have you tried all troubleshot steps that I listed in my previous reply? and what's the result?

    There are some factors that may be blocked VS to update license, like the internet network, the default browser, vs itself and more...

    Please open an administrative CMD window and navigate to C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE and run the command: devenv.exe /resetuserdata to reset the user data in VS and reopen VS, then sign in with your Microsoft account again.

    If this issue persists, I recommend you create a new thread for your issue and we will help to continue researching and thank you for your understanding.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Tuesday, October 4, 2016 6:04 AM
    Moderator
  • Greetings Sara,

    thank you for your reply.

    It seems that the /resetuserdata did its job. :)

    I am new to programming, but this seems to be more related to magic as to science. You spend much energy and time trying to get something to work until you actually can write the code.

    But anyway. Thanks again.

    My best regards!

    Claudiu

    Tuesday, October 4, 2016 5:26 PM
  • Hi Claudiu,

    I'm so glad to hear that your issue is solved and thank you for your sharing.

    BTW, if you think your reply or my reply is helpful, please mark it as answer and it will help other community members who have the same or similar to easier search them, thank you for your understanding.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Wednesday, October 5, 2016 4:38 AM
    Moderator
  • VS2015 was getting the same registration error (0008001) saying bad proxy or network connection also.  I am on Windows 8.1.  The solution was:

    Make sure IE 11 is installed and up to date.  

    Go into IE 11 and "safety" -> "delete browsing history".  Select all.  Remove all histories for all topics.  Shut it down.  Restart it.

    Go back to VS2015.  Click check license again.  Should work just fine now.  Have a good day!

    Thursday, November 17, 2016 1:37 PM
  • Hi advrider,

    Welcome to the MSDN forum.

    Thank you very much for your sharing, it will help other community member who have the same or similar issue.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 18, 2016 6:45 AM
    Moderator