locked
Coded Ui Test Automation RRS feed

  • Question

  • Hi,

         The structure of my project as follows. 

    FirstProject-->CodedUiTest1.cs-->CodedUiTestMethod1(),

                                                     CodedUITestMethod2(),

                                                      .

                                                      .

                                                     CodedUiTestMethod15(). 

    Now I added another class to the same project.

    FirstProject->CodedUitest2.cs-->CodedUiTestMethod1(),

                                                    CodedUiTestMethod2()

      Now I want to run only the methods which are in CodedUiTest2.cs. How is it possible?

    Actually when I run the project using Test->Run->SelectedTests, the whole methods in the entire project are executing instead of CodedUiTest2.cs methods. Even though if I select the methods from test explorer the same thing was happened. But its working for failed tests.

    Can some one help me if I want to test only CodedUiTestMethod2() in CodedUiTest2.cs, how to run this particular method?

    Thanks

    Gousiya


                                              

    Friday, September 26, 2014 11:02 AM

Answers

  • Hi Gousiya,

    Thank you for posting in the MSDN forum.

    According to your description, I suggest you could refer the following steps to run your CodedUiTestMethod2() in CodedUiTest2.cs.

    Step1: Change the way that tests are organized, choose the down arrow next to the Group By button and select a Class as new grouping criteria on Test Explorer.

    Reference:

    Step2: Right-click your firstproject->select Clean your firstproject->select Rebuild your firstproject on solution explorer.

    Step3: You could select the CodedUITestMethod2() in CodedUiTest2.cs, and then right- click the CodedUITestMethod2()->choose Run Selected Tests on Test Explorer.

    Or you can also select the CodedUITestMethod2() on Test Explorer, and then run the CodedUITestMethod2() from Test->Run->Selected Tests.

    Hope it help you!

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.


    • Edited by Tina-Shi Saturday, September 27, 2014 2:19 AM
    • Marked as answer by Tina-Shi Monday, October 6, 2014 9:37 AM
    Saturday, September 27, 2014 2:19 AM
  • Hi Gousiya,

    Glad to receive your reply.

    According to your description, you mean that you get the above error while generating Coded for the Coded UI Test, am I right?

    If yes, I find two similar thread about this issue, maybe you get some useful information.

    Reference:

    http://social.msdn.microsoft.com/Forums/en-US/bff4fa44-00f9-4888-97eb-9572e613d9ac/coded-ui-test-in-vs-2012-rc-value-cannot-be-null-while-generating-the-code-from-coded-ui-test?forum=vsautotest

    http://stackoverflow.com/questions/12867798/ui-tests-visual-studio-2012

    In addition, since one thread for one issue, if the previous issue has been resolved. If you have any questions about the issue, it would be better if you can create a new thread in our forum. So I suggest you could post a new issue to a new thread in our forum, we will follow up your new issue:)

    Thanks for supporting my work.

    Have a nice day!

    Best Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.


    • Edited by Tina-Shi Monday, October 6, 2014 9:38 AM
    • Marked as answer by Tina-Shi Monday, October 6, 2014 9:38 AM
    Monday, September 29, 2014 10:59 AM

All replies

  • Hi Gousiya,

    Thank you for posting in the MSDN forum.

    According to your description, I suggest you could refer the following steps to run your CodedUiTestMethod2() in CodedUiTest2.cs.

    Step1: Change the way that tests are organized, choose the down arrow next to the Group By button and select a Class as new grouping criteria on Test Explorer.

    Reference:

    Step2: Right-click your firstproject->select Clean your firstproject->select Rebuild your firstproject on solution explorer.

    Step3: You could select the CodedUITestMethod2() in CodedUiTest2.cs, and then right- click the CodedUITestMethod2()->choose Run Selected Tests on Test Explorer.

    Or you can also select the CodedUITestMethod2() on Test Explorer, and then run the CodedUITestMethod2() from Test->Run->Selected Tests.

    Hope it help you!

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.


    • Edited by Tina-Shi Saturday, September 27, 2014 2:19 AM
    • Marked as answer by Tina-Shi Monday, October 6, 2014 9:37 AM
    Saturday, September 27, 2014 2:19 AM
  • Hi

    The following error came after clicking the save button. Even though i entered all mandatory filed values the same error came.

    Can some one help me why this type of error came.

    Thanks,

    Gousiya

    Monday, September 29, 2014 10:01 AM
  • Hi Gousiya,

    Glad to receive your reply.

    According to your description, you mean that you get the above error while generating Coded for the Coded UI Test, am I right?

    If yes, I find two similar thread about this issue, maybe you get some useful information.

    Reference:

    http://social.msdn.microsoft.com/Forums/en-US/bff4fa44-00f9-4888-97eb-9572e613d9ac/coded-ui-test-in-vs-2012-rc-value-cannot-be-null-while-generating-the-code-from-coded-ui-test?forum=vsautotest

    http://stackoverflow.com/questions/12867798/ui-tests-visual-studio-2012

    In addition, since one thread for one issue, if the previous issue has been resolved. If you have any questions about the issue, it would be better if you can create a new thread in our forum. So I suggest you could post a new issue to a new thread in our forum, we will follow up your new issue:)

    Thanks for supporting my work.

    Have a nice day!

    Best Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.


    • Edited by Tina-Shi Monday, October 6, 2014 9:38 AM
    • Marked as answer by Tina-Shi Monday, October 6, 2014 9:38 AM
    Monday, September 29, 2014 10:59 AM