locked
Music Application does not play MP3 audio, but Zune and Media Player do

    Question

  • I installed the Release Preview and VS on a new machine.

    The Music player and all of the sample code projects that play MP3 files do not play any audio, and the sound icon has an X on it.  It does not matter if I select the file manually in the music player from the dialog, or play one of the artist that are in the music player.

    However when I play audio from the file explorer and choose the player of Zune or Windows Media Player the play fine, when I choose the music player they do not.

    Monday, June 18, 2012 2:00 AM

Answers

  • It sounds like when you installed Zune it may have done something to the audio Codecs.  Have you tried uninstalling Zune and reverting your machine back to an earlier time?

    -Jeff


    Jeff Sanders (MSFT)

    Monday, June 18, 2012 8:18 PM
    Moderator
  • Hey Mike,

    I tried installing the Zune software to make sure that we don't have an app compatibility issue. The Zune software installed with no problems and it did not override any of my codecs. In other words I'm not sure that Zune is the root cause of the issue. Jeff's suggestion is sound though. You can try uninstalling the Zune software and see if that resolves your issue.

    I hope this helps,

    James


    Windows Media SDK Technologies - Microsoft Developer Services - http://blogs.msdn.com/mediasdkstuff/

    Thursday, June 21, 2012 12:53 AM
    Moderator

All replies

  • It sounds like when you installed Zune it may have done something to the audio Codecs.  Have you tried uninstalling Zune and reverting your machine back to an earlier time?

    -Jeff


    Jeff Sanders (MSFT)

    Monday, June 18, 2012 8:18 PM
    Moderator
  • Hey Mike,

    I tried installing the Zune software to make sure that we don't have an app compatibility issue. The Zune software installed with no problems and it did not override any of my codecs. In other words I'm not sure that Zune is the root cause of the issue. Jeff's suggestion is sound though. You can try uninstalling the Zune software and see if that resolves your issue.

    I hope this helps,

    James


    Windows Media SDK Technologies - Microsoft Developer Services - http://blogs.msdn.com/mediasdkstuff/

    Thursday, June 21, 2012 12:53 AM
    Moderator