locked
Autocomplete intellisense not working in Visual Studio 2010 Ultimate RC

    Question

  • Using C# in Visual Studio 2010 Ultimate RC intellisense only works when I use crtl-space, When typing I do not get autocomplete and after typing "." after a method or variable I do not get a drop down list of suggestions. My settings  in Tools --> Options --> TextEditor -C# match exactly my settings in VS 2008 where intellisense works as expected.

    What can I do to correct this?

    Thanks.
    • Moved by YiChun Chen Thursday, February 18, 2010 3:41 AM VS2010 issue (From:Visual Studio Setup and Installation)
    • Moved by Aaron Ruckman - HPQ Friday, February 19, 2010 8:47 AM moving this thread to the C# IDE forum. (From:Visual Studio 2010 Install and Setup)
    Wednesday, February 17, 2010 9:04 PM

Answers

All replies

  • Hi SR1995,

    I am moving this thread from Base "Visual Studio Setup and Installation" forum to the "Visual Studio 2010 Setup and Installation" forum, since the issue is related to VS2010. There are more experts in the "Visual Studio 2010 Setup and Installation" forum.

    Thanks

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, February 18, 2010 3:41 AM
  • Hello,

    As far as I researched, there is a known issue about the VS 2010 Intellisense. The issue can cause Intellisense dismissed or VS crashed.

    You can find more information from Scott Gu's blog,
    http://weblogs.asp.net/scottgu/archive/2010/02/15/patch-for-vs-2010-rc-intellisense-crash-issue-now-available.aspx
    , as well as a hotfix for the issue.

    If you still encounter this, I suggest you raise a feedback in connect site to report it.


    Best regards,
    Ji Zhou
    MSDN Subscriber Support in Forum
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, February 22, 2010 2:31 AM
    Moderator
  • Hello SR1995,

    Does that hotfix work for you? What is the status of the issue in your side?


    Best regards,
    Ji Zhou
    MSDN Subscriber Support in Forum
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Wednesday, February 24, 2010 2:45 AM
    Moderator
  • The hotfix did not correct my Intellisense problem. The situation remains as in my post of 2/17.

    Thank you.


    Wednesday, March 03, 2010 10:07 PM
  • Hello SR1995,

    I cannot reproduce the issue. Then could you please try to reset your Visual Studio by,

    1. Make sure no devenv.exe is running.
    2. Try running from Start->Run:
       devenv /resetuserdata (This causes a new devenv process run to do the resetting job)
    3. Open task manager and check that the devenv process finishes (this takes a couple of minutes)


    If this still does not resolve the issue, I suggest you submit this issue via connect site.
    https://connect.microsoft.com/VisualStudio



    Best regards,
    Ji Zhou - MSFT
    MSDN Subscriber Support in Forum


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Proposed as answer by Jugal Panchal Tuesday, September 27, 2011 11:27 AM
    Friday, March 05, 2010 2:17 AM
    Moderator
  • Hello.

    I had the same problem - its not a bug and misunderstod above:

    You and I accidentally switched into low-impact IntelliSense mode by pressing Ctrl+Alt+Space. Just hit Ctrl+Alt+Space to go back to the thing you want.

    (I suppose you are not having this problem any more, but other peope might come by ;) )

    More about this problem here:

    http://social.msdn.microsoft.com/Forums/en/vseditorprerelease/thread/0b58d586-520b-49c4-bb78-e1d1eb5bd309

    Best regards.

    Anders Both - Denmark.


     

    • Proposed as answer by Anders Both Monday, March 22, 2010 9:30 AM
    • Marked as answer by Ji.ZhouModerator Monday, March 22, 2010 11:34 AM
    Monday, March 22, 2010 9:12 AM
  • I was having the same problem this morning.  The Ctrl+Alt+Space suggestion didn't work in my case but running devenv with the /resetuserdata argument did.  Thanks for the help.
    Wednesday, March 16, 2011 2:54 PM
  • Hi Anders,

     

    Thank you very much for the info you shared.

    Ctrl+Alt+Space fixed the IntelliSense in my case.

     

    Regards,

    Deepak

    Sunday, March 27, 2011 1:04 AM
  • none of the above solved my problem. I found out that in the web.config file, the system.web > pages > controls had several dlls that were no longer being referenced by the project (but still had 'asp' prefixes):

    When I removed the top 4 Microsoft.Web.Preview tags (carried over from several versions of code and no longer used or referenced), it suddenly worked.

     

     

        <pages theme="DefaultTheme">
          <controls>
            <add tagPrefix="asp" namespace="Microsoft.Web.Preview.UI" assembly="Microsoft.Web.Preview" />
            <add tagPrefix="asp" namespace="Microsoft.Web.Preview.UI.Controls" assembly="Microsoft.Web.Preview" />
            <add tagPrefix="asp" namespace="Microsoft.Web.Preview.Search" assembly="Microsoft.Web.Preview" />
            <add tagPrefix="asp" namespace="Microsoft.Web.Preview.Diagnostics" assembly="Microsoft.Web.Preview" />
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add tagPrefix="ajaxToolkit" namespace="AjaxControlToolkit" assembly="AjaxControlToolkit" />
          </controls>
        </pages>
    


     


    David
    Wednesday, August 10, 2011 2:39 PM
  • Resetting Visual Studio as Ji.Zhou said... now it is working.
    So Reset by "devenv /resetuserdata"
    Tuesday, September 27, 2011 11:32 AM
  • This solved my problem as well, so I'd like to second the "proposed as answer".
    Sunday, October 02, 2011 3:07 PM
  • Resolved my issue by run "devenv /resetuserdata" command
    KVReddy
    Thursday, January 19, 2012 3:11 PM
  • Anders,

    Ctrl-Alt-Space only turns drop-down box "automatic selection" on or off. You still get the drop down box whether this is on or off.

    BTW - the problem causing my missing intellisense was me having turned off compilation for the class I was working in - der!

    Steve 

    • Proposed as answer by Dave-JD Tuesday, March 20, 2012 2:33 PM
    Sunday, January 29, 2012 1:16 AM
  • I had the same problem, I tried different methods suggested in different discussion forms, but none worked fine in my case. But in between I found the intellisense is not working for a single solution and finally found the compilation error makes the intellisense not working. So in order to reach your problem you may go through these steps

    1. Compile the entire solution and correct the compilation error. If it is not working do the following steps too
    2. devenv.exe /ResetSettings
    3. devenv /resetuserdata
    4. Goto settings and check the following setting are there

    • Proposed as answer by Claudia177 Thursday, July 12, 2012 7:18 PM
    Friday, March 02, 2012 10:00 AM
  • Thanks it works for me :)
    Monday, March 12, 2012 10:03 PM
  • I had a similar problem, somehow one of my files dropped out of the project, so "String." would bring up intellisense, but "this." would not. Adding the file to the project again through Solution Explorer fixed it.
    Tuesday, March 20, 2012 2:34 PM
  • I had the same problem, but my VS 2010 was not showing the CSS classes with intellisense. This tip resolved my problem. Thank you very much.
    Sunday, April 29, 2012 3:01 PM
  • Hello SR1995,

    I cannot reproduce the issue. Then could you please try to reset your Visual Studio by,

    1. Make sure no devenv.exe is running.
    2. Try running from Start->Run:
       devenv /resetuserdata (This causes a new devenv process run to do the resetting job)
    3. Open task manager and check that the devenv process finishes (this takes a couple of minutes)


    If this still does not resolve the issue, I suggest you submit this issue via connect site.
    https://connect.microsoft.com/VisualStudio



    Best regards,
    Ji Zhou - MSFT
    MSDN Subscriber Support in Forum


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    It works for me!
    Sunday, April 29, 2012 3:02 PM
  • Worked for me as well !!! Thanks.
    Wednesday, May 30, 2012 6:00 AM
  • This solution works for me Thanks Rajin.
    • Proposed as answer by Mulpuri Thursday, June 21, 2012 8:55 PM
    Thursday, June 21, 2012 8:54 PM
  • Thank you..... it worked for me
    Wednesday, June 27, 2012 2:08 PM
  • Worked for me as well, had to do the deveenv /resetuserdata.  The Ctrl+Alt+Space didn't work so did the command line solution.

    Thanks :)

    Thursday, June 28, 2012 9:22 PM
  • I had this issue when I accidentally opened my site in VS from the folder containing the wwwroot (rather than opening the wwwroot directly).  In my case, I noticed that the page declaration was indicating an error. 

    Tuesday, July 17, 2012 3:24 PM
  • This works for me.

    Thanks a lot.

    • Proposed as answer by AnithRaj Monday, October 15, 2012 7:19 AM
    Tuesday, August 07, 2012 6:06 PM
  • in case u have done any mistakes in the code intellisence will not work.....check the code....


    Monday, October 15, 2012 7:20 AM