none
BizTalk 2010 - WCF-Custom Adapter with sqlbinding - rror was encountered while attempting to transmit the message RRS feed

  • Question

  • BizTalk 2010 RTM version with SQL 2008 R2 .

    An intermittent issue with the WCF-Custom adapter with sqlbinding, calling a SQL stored proc as below

    Message gets suspended in BT Admin console  with "An internal server error was encountered while attempting to transmit the message" .

    Event log shows 

    A message sent to adapter "WCF-Custom" on send port "xxx" with URI "mssql://server/db?" is suspended.  Error details: Unknown Error Description 


    Any advice please. Thanks

    Sullu.


    http://biztalkguide.blogspot.com/ Please mark as answer if this solved the issue.Thanks

    Wednesday, April 10, 2013 1:47 PM

All replies

  • A message sent to adapter "WCF-Custom" on send port "xxx" with URI "mssql://server/db?" is suspended.  Error details: Unknown Error Description 

    Hi,

    Do you have any other error messages when you get this error ? It will provide us more information about your problem.

    You could try to follow below blog's method, it may help you.

    Please check: http://thoughtstuff.co.uk/2011/11/biztalk-wcf-custom-adapter-sqlbinding-silently-consuming-messages/

    Regards,


    Chen Yu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, April 12, 2013 7:01 AM
    Moderator
  • Thanks for your response, Chen Yu.

    It only gives very generic error message as "Unknown Error Description".No further details could be found anywhere, unfortunately :(

    The link provided in your response applies to polling only scenario or for solicit request - response as well ?

    Thanks .

    Sullu





    http://biztalkguide.blogspot.com/ Please mark as answer if this solved the issue.Thanks

    Friday, April 12, 2013 8:52 AM
  • Hi,

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Regards,


    Chen Yu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, April 15, 2013 7:10 AM
    Moderator
  • Hi,

    Can you try to update to latest CU for Adapter Pack: http://support.microsoft.com/kb/2572999

    And here is sample that you can compare with your code: http://biztalkia.blogspot.com/2011/10/biztalk-adapter-pack-2010-wcf-custom.html


    Regards,
    Christian HL
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Molly Chen_Moderator Monday, April 22, 2013 3:45 AM
    • Unmarked as answer by amsullu Monday, December 30, 2013 3:08 PM
    Thursday, April 18, 2013 4:19 AM
  • Hi Chen

    Is there any update on this please ?

    I have applied the latest CU and have noticed the following issue.

    BizTalk 2010 Enterprise Edition with BizTalk 2010 CU6 and CU3 for BizTalk Adapter Pack works fine , no issues noticed.

    However ,

    On a DEV VM ,BizTalk 2010 Developer Edition with BizTalk 2010 CU6 and CU3 for BizTalk Adapter Pack still gives the error mentioned in this post.

    In addition Microsoft BizTalk Adapter Pack ,Microsoft BizTalk Adapter Pack(x64) & WCF LOB Adapter SDK are also installed .

    Below is the Error message.

    Message gets suspended in BT Admin console  with "An internal server error was encountered while attempting to transmit the message" .

    A message sent to adapter "WCF-Custom" on send port "xxx" with URI "mssql://server/db?" is suspended.  Error details: Unknown Error Description 

    Could you please check and advice what needs to be done to resolve this ? Thanks .

    Regards,

    Sullu

     


    http://biztalkguide.blogspot.com/ Please mark as answer if this solved the issue.Thanks

    Monday, December 30, 2013 2:36 PM