locked
Creating Personel web site !! HELP RRS feed

  • Question

  • User1542408043 posted
    Hi All, İ am trying to create web site but when i lanuch program i take below error message : An er ror has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Shared Memory Provider, error: 40 - Could not open a connection to SQL Server) Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42 plesae help me how can i solve thi problem... Best regards...
    Friday, December 30, 2005 7:32 AM

All replies

  • User2047060128 posted

    The error message is so general that there is not one specific thing that can be done to fix it. Follow the usual checklist:

    1. Is the database service started?

    2. Is it being offered on the standard port?

    3. Is your userid and password correct?

    4. Can you connect to it using the database tools and run queries?

    5. Does your SQL Server setup allow remote connections like the error message says?

    I've never had your issue so I can't say exactly what is going to fix it.

    Friday, December 30, 2005 10:09 AM
  • User1542408043 posted

    thanks,

     i am new in visual web devp. i  just downloaded  web express and i compiled

    prepared personel web site then received this error message.

    i looked slq server it was stopped then i tryed to run it but failed 

    you asked:  Is your userid and password correct? didn't ask me userid and password..

    Can you connect to it using the database tools and run queries? i think ı haven't databese tools

    Could  you   explane plesase how can i lounch it correct?

    Best regards..

    Wednesday, January 4, 2006 4:29 PM
  • User595806616 posted
    Are you using SQL Server 2005 or SQL Server 2005 Express Edition?
    Thursday, January 5, 2006 10:58 AM
  • User2047060128 posted

    Yakup,

    You are asking such general questions that I think it is going to be hard to help you. Just saying it doesn't work is not going to give people too much to go on.

    Thursday, January 5, 2006 11:09 AM
  • User-2044729356 posted

    It also sounds like you only downloaded Visual Web Developer express and told it no for the option of SQL Express. If you are just trying to get a test site up and running you should download SQL express as well.

     

    Sunday, January 8, 2006 6:17 PM
  • User-1736609513 posted

    Hi,  I am having a similar problem.

    I have VWD2005 and SQL Express running locally, and can get a PWS kit running without problems on the local machine (before I modify the web.config for the SQL server address where the site is hosted).

    When the site is hosted locally, I can login using a account created in the ASP configurator, no problems, I can then create albums etc.

    When the site is uploaded to the web address, with the web.config updated to the godaddy SQL server address, I can see the site, but cant login!

    I am slowly going mad with this problem.  I have checked the SQL settings in the godaddy host panel, no problems.  I have also added the personal-add.sql schema to the SQL database.

    Any ideas?

    Thanks in advance

    Friday, January 13, 2006 3:17 AM
  • User595806616 posted

    Have you double checked that both of your connection strings exactly match the connection strings provided by Godaddy? As well, you may want to try to explicitly connect using TCP like this.

    Server=tcp:whsql-v04.prod.mesa1.secureserver.net;

     

     

    Friday, January 13, 2006 11:09 AM
  • User-1736609513 posted

    Hi Jeremy,

    I tried to use the server address as you suggested, but that caused the site not to load.

    The connection string section on godaddy's website has been pasted straight into my web.config, with the server address, DB name, UserID and Pword all updated.

    It seems ok to me as the page will load, it just wont let anyone log in.  If any of the web.config was incorrect, wouldnt the page simply not load?

    Also, I am new to this asp.net, but I find it hard to believe that since godaddy's sql server will not allow remote access, anytime i want to edit/update the content on my site, I have to change the connection strings in the web.config NOT to look for the whsql-v05.prod.mesa1.secureserver.net address?

    am i missing something?  Surely you can set it up so when you load the local site on VWD2005, I can edit the site, run it, log in etc, then upload to the web without editing the web.config??

    Thanks for your help!

    Sunday, January 15, 2006 1:49 AM
  • User1052258516 posted

    Hi,  I am having a similar problem.

    I have VWD2005 and SQL Express running locally, and can get a PWS kit running without problems on the local machine (before I modify the web.config for the SQL server address where the site is hosted).

    When the site is hosted locally, I can login using a account created in the ASP configurator, no problems, I can then create albums etc.

    When the site is uploaded to the web address, with the web.config updated to the godaddy SQL server address, I can see the site, but cant login!

    I am slowly going mad with this problem.  I have checked the SQL settings in the godaddy host panel, no problems.  I have also added the personal-add.sql schema to the SQL database.

    Any ideas?

    Thanks in advance

    You said "I have also added the personal-add.sql schema to the SQL database" but what about the ASP.NET Membership tables, stored procedures, views and of course the data from the aspnet.mdf?  These also need to be in your database as well.  If the only problem with your site is that you cannot log in then I would assume this is the problem.

    If this is the issue then you will need to script the entire aspnet.mdf database and run the script like you did with the personal-add.sql script.  Also you will need to extract the data in there as well which can be done.  You can get the aspnet.mdf script from this location: http://forums.commercestarterkit.org/files/471/download.aspx.  You will also have to get the data out of 5 of the aspnet database tables into your database as well.  The tables are: 'aspnet_Applications', 'aspnet_Users', 'aspnet_Membership', 'aspnet_Roles' and 'aspnet_UsersInRoles'.  The data must be inserted into the tables in the order I listed above due to the relationships between the tables.

    A better way is to see if GoDaddy allows you to restore your database from a backup location that you have access to.  If they do then you can make a backup of your database locally, ftp it up to your site or a location that they specify and then restore that database to your database.  I realize that you are new to ASP.NET developement and all and this might be overwhelming but it might be worth looking in to.  This will require you to download the SQL Server Express 2005 Management Studio, install it, attach the aspnet.mdf to the SQL Server Express database engine and then use the tool to create a backup of the database (a file) which will be uploaded and restored some how throught the control panel.  And of course when you attach it to the engine your connection string will change in the web.config of course. 

    Are we having fun yet?  [8-)]

    - Will

    Sunday, January 15, 2006 12:39 PM
  • User2091690594 posted

    Hi All, İ am trying to create web site but when i lanuch program i take below error message : An er ror has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Shared Memory Provider, error: 40 - Could not open a connection to SQL Server) Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42 plesae help me how can i solve thi problem... Best regards...

    I am getting the same error.  I have tried a few things.  I want to deploy to my ISP, so I have to use the built in version of SQL 2005.  When I test using Cassini, everything works fine.  I have deployed to IIS 6.0 and 5.1 and both give me the error above.  I read on Wrox forum a way to make it work, but that didn't work.  I would really like to make this work if possible and understand what is causing the problem. 

    Wednesday, January 18, 2006 6:27 PM
  • User-719005538 posted

    I was having the same problem getting my web site up, but I found that there are help documents in the godaddy site that will give you the steps you need to get the personal web site starter kit working. Here is what I had to do.

    I verified that the site worked on my system that has VS2005 RTM installed. Then I uploaded the site to their servers and it wouldn't display. Next I tried creating a MySQL instance, but realized that wasn't my problem.

    So, after reading, I found that you have to purchase their 10$ a month deluxe package to get ASP.NET 2.0 runtime. So I upgraded my account. While that was happening, I read their help files on ASP 2.0 and there were about 5-10 articles on setting up the kit.

    1. Purchase the deluxe package and domain name. Let that replicate across the routers on the internet for 24 hours while you tweak the site on your personal machine. http://www.godaddy.com

    2. Log into the site and upgrade your ASP runtime from 1.1 to 2.0. Then let that finish working. http://help.godaddy.com/article.php?article_id=688&topic_id=&&

    3. Go to the SQL page and select to create a database on the SQL server. Select the option to add ASP schema and then click the create the database button. When that is done, you have an empty database with schema for ASP, but not for the starter kit. This link tells you how to configure the database. http://help.godaddy.com/article.php?article_id=694&topic_id=&&

    4. Go to the query analyzer and paste the contents of the personal-add.sql script into the analyzer window and submit it. You should see a bunch of "command completed" messages letting you know it added the information to the DB. http://help.godaddy.com/article.php?article_id=695&topic_id=&&

    5. Make note of the SQL server that you are connected to in the SQL window. It will be something like whSQL-06 or similar. Then look at the DB number you were given. Something like DB_4902. This information will go in the web.config file using the information godaddy specifies here for the connection strings. http://help.godaddy.com/article.php?article_id=689&topic_id=&&

    6. Now you should be able to bring up the home page and register a new user. This will add that user into the database tables. Once that is done go back to the SQL query analyzer and run the T-SQL query on this help page to make that user an admin for the site. http://help.godaddy.com/article.php?article_id=886&topic_id=&&

    You should now be able to login as that user and be an admin of the site. You can reach the hidden management pages by selecting http://www.yourdomain.com/details.aspx or /photos.aspx or /albums.aspx web pages.

    If this gets anyone through it easier, I would love to know it. :) Drop me a note at icq69@yahoo.com. Good luck.

    Nick

    Sunday, February 12, 2006 10:38 PM
  • User-1537835185 posted
    So, did you do all these steps BEFORE you uploaded any of your site (databases, pages, etc.)?

    I am having so many problems... I'm tempted to start all over. Your list sounds very complete, and I have read many of those help files. It's just that the last webpage I made was in the days of html and you just upload you page, and the photos, make sure it was called index and life was good.

    Thanks!
    Friday, March 3, 2006 3:22 PM
  • User901147786 posted

    Siasil,

    Your list is excellent. I had been stuck for a week trying to get my page to show up on my godaddy host server with no success. Now it shows up and is linked to the database.

    But I am not quite there yet: I am stuck at the last step. My application is just the Visual.net photo startup kit. I created a user name, went to godaddy and assigned the "Administrator" role to that user name by running all the SQL scripts listed there (http://help.godaddy.com/article.php?article_id=886&topic_id). That step worked fine since I could find my user name in the aspnet_Users table and the user-role association in the aspnet_UserInRoles table. The keys are correct.

    BUT: When I go back to the front page of my website, I still cannot log in ??? Any idea ?

     

    Thanks.

     

     

    Wednesday, October 8, 2008 6:55 PM
  • User901147786 posted

    Ok I got it !

    The missing step what to set the IsApproved field to TRUE in the aspnet_Membership tabkle for my admin user.

    I found the solution by looking at all my tables in godaddy and changed the field manually (which was a pain because the UI is buggy and you can't scroll down to the update button after you change the value of that field. But you can use an SQL script to do it: http://help.godaddy.com/article/885

    Godaddy has its help on ASP scattered everywhere. I found this page which I recommend you bookmark though: http://help.godaddy.com/search?topic_id=216&q=web+site

     Good luck ! 

     

    Thursday, October 9, 2008 12:04 PM
  • User901147786 posted

    Ok I got it !

    The missing step what to set the IsApproved field to TRUE in the aspnet_Membership table for my admin user.

    I found the solution by looking at all my tables in godaddy and changed the field manually (which was a pain because the UI is buggy and you can't scroll down to the update button after you change the value of that field. But you can use an SQL script to do it: http://help.godaddy.com/article/885

    Godaddy has its help on ASP scattered everywhere. I found this page which I recommend you bookmark though: http://help.godaddy.com/search?topic_id=216&q=web+site

     Good luck ! 

     

    Thursday, October 9, 2008 12:05 PM