none
What happened to Windows Photo Manager in R2? RRS feed

  • Question

  • I was using Windows Photo Manager in Server 2008 R1 and it seems to have been removed for R2.

    Just like Windows Explorer, Microsoft took a perfectly decent application and and tarted it up till it is total garbage. I installed Windows Live and all the rest of the ____ that comes with it in order to get the latest messenger, onto my Windows 7 system, and immediately uninstalled and I'm not about to put all that junk on my server.

    Anyone know how to get the original Windows Photo Manager back? Or a decent alternative?

    Thanks, Dave
    • Edited by CodeSlinger Wednesday, January 13, 2010 11:51 PM spelling
    Wednesday, January 13, 2010 11:38 PM

All replies

  • Hi

    • In Windows Server 2008 R2, by default Desktop Experience is not installed, hence when you try to open a photo, it opens in Paint instead of Windows Photo Viewer.


    • To get the Windows Photo Viewer back, Open Server Manager > Features > Add > Desktop Experience > Install > Click on Add Required Features > Install, reboot the server once Install is completed. Upon reboot you should see Windows Photo Viewer is available.




    Omanakuttan M.K.
    Thursday, February 25, 2010 5:35 PM
  • I have Windows Experience installed already. And the description even says this:

    "Desktop Experience includes features of Windows® 7, such as Windows Media Player, desktop themes, and photo management. Desktop Experience does not enable any of the Windows 7 features by default. You must manually enable them."

    But still there is no photo manager. I don't see anywhere to "manually enable" it.

    I believe, just like Windows 7, Server R2 forces you to add Live Photo Gallery which I really do not want to use. I would much prefer the non Live version of the old Photo Gallery that was in R1.

    In any event, MSFT needs to fix the documentation!

    Thanks, Dave
    • Edited by CodeSlinger Friday, February 26, 2010 5:24 AM clarify
    Thursday, February 25, 2010 10:01 PM
  • Hi

    • In Windows Server 2008 R2, by default Desktop Experience is not installed, hence when you try to open a photo, it opens in Paint instead of Windows Photo Viewer.


    • To get the Windows Photo Viewer back, Open Server Manager > Features > Add > Desktop Experience > Install > Click on Add Required Features > Install, reboot the server once Install is completed. Upon reboot you should see Windows Photo Viewer is available.




    Omanakuttan M.K.

    Sorry, but this is NOT the answer and is actually flat out WRONG as far as I can tell. See my first followup post as I already have the Desktop Experience installed and the Photo Viewer is not part of it even though some of the documentation claims this which is also wrong. It would be nice if it was put back but currently it is just not there. Thanks, Dave
    Tuesday, March 16, 2010 3:52 PM