locked
Does Xamarin studio support IOS 5.x RRS feed

  • Question

  • User5307 posted

    Hi, In "Project Options" "Build/IOS Build SDK Options" I can only choose SDK Version 6.0.

    Is there a way to choose an earlier IOS SDK version?

    Thanx

    Jra

    Monday, March 11, 2013 1:36 AM

Answers

  • User28 posted

    This setting is for the native SDK. It doesn't affect what APIs you can use, it just affects which Apple SDK is used when performing the native parts of the compilation. In general you should leave this setting as "Default" and it will pick up the newest one you have installed.

    If you want to run on older devices, set the "Deployment target" instead.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, March 11, 2013 4:43 PM

All replies

  • User1044 posted

    You need to install the older SDKs from Xcode (by default, Apple only bundles the latest SDK).

    Monday, March 11, 2013 11:48 AM
  • User59 posted

    You can build against 6.x and it'll run on 4.3 if you dont use 5.x or 6.x specific apis... you don't NEED 5.x (or 4.3) unless you want to use that versions emulator, I think.....

    keep in mind, apple will not accept builds done with anything but the latest SDK (and possibly one back - so 6.1 and 6.0 at the moment)

    Monday, March 11, 2013 3:21 PM
  • User28 posted

    This setting is for the native SDK. It doesn't affect what APIs you can use, it just affects which Apple SDK is used when performing the native parts of the compilation. In general you should leave this setting as "Default" and it will pick up the newest one you have installed.

    If you want to run on older devices, set the "Deployment target" instead.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, March 11, 2013 4:43 PM