locked
Issue - Dataflow execution failure status on pipeline execution status RRS feed

  • Question

  • Hi,

    Recently, we have seen some issues on data flow executions. We have some pipelines which execute data flows. Sometimes, due to cluster allocation errors/internal errors on data flow ,status of data flow is not reported as failed on pipeline, causing pipelines status as "In Prgoress" still running. Ideally, when flow status is failed so the pipeline status should reported as failed We have seen this problem two times in week. 

    Due to this status issue, last time pipeline ran for almost 51 hours without doing anything. I had to cancel pipeline manually. Could you please investigate further.

    Below is subscription details for your analysis

    Subscription ID:  XXXXXXXXXXXXXXXXXXX

    Datafactory Name: df-data-core

    Pipeline Run ID: 63aa4f39-fab4-4eab-bd1d-d02da37c2e67

    Regards,

    Mansing


    Monday, April 27, 2020 6:37 AM

All replies

  • Hi Mansing-Patil,

    Thanks for reaching out and sharing the details. We will further investigate the issue and will get back to you. In the meantime could you also please share activity runID that is taking longer time?

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Monday, April 27, 2020 5:25 PM
  • Hi,

    Here is activity run ID #"15751059-f768-4e54-b41a-3a603a16d785" which you can look into. 

    Regards,

    Monday, April 27, 2020 6:33 PM
  • Hi Mansing-Patil,

    Thanks for the details. After verifying the runID's from the screenshot, pretty sure it could be an issue specific to "Eiendom_DW_DF_Fact_Common" data flow activity. It needs a deeper analysis to understand what is happening with that particular Data Flow activity.  It could an issue with the transformation logic in that particular activity. We have enabled a one-time free technical support for your subscription to work closely on this issue. Please follow the steps mentioned in the email to file a support request. 

    Let us know here, once you have done the same. 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Thursday, April 30, 2020 7:49 PM
  • Hi Mansing-Patil,

    Following up to see if you have got chance to see my previous comment.  

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Monday, May 4, 2020 6:41 PM
  • Hi Kranti,

    Sorry for late reply. I been in process to investigate further. Issue is not happening on any perticular flow. its random and ocurs sometime. I tried to raise request as per your instructions on subscription, but I dont get option to create ticket for microsoft support. Am I missing anything here? 

    I can see issue created in service health but dont have option to create ticket. 

    Hope you can help me here

    Mansing

    Tuesday, May 5, 2020 6:50 AM
  • Hi Mansing-Patil,

    Thanks for response. I have sent an updated email, please follow the instructions and let me know how it goes. 

    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Tuesday, May 5, 2020 7:48 AM