none
Spinning Wheel icon not being displayed on ReportViewer control RRS feed

  • Question

  • Hello,

    I added a ReportViewer control to my ASP.NET app and everything seems to be working fine except that the spinning wheel icon that is supposed to pop up as you are waiting for the report to render does not get displayed.

    I'm using VS2008 and version 9.0.0.0 of Microsoft.Reporting.Webforms.

    This is the control markup:

    <form id="form1" runat="server">
      <div>
    	<rsweb:ReportViewer ID="ReportViewer1" ProcessingMode="Remote" AsyncRendering="false" SizeToReportContent="true" runat="server">
    	</rsweb:ReportViewer>
    
      </div>
    </form>
    
    
    
    
    
    
    
    

    Any help would be appreciated! 

    Wednesday, February 9, 2011 9:55 PM

All replies

  • Hi,

    I am getting the same issue with Report viewer 2010 SP1.  However, I noticed in your example you have AsyncRendering set to false.  Have you tried changing this to true and adding a ScriptManager?

    In my case the style attribute display: is set to none. Setting this to inline whilst debugging forces the item to display.

    <form id="report_render_result" runat="server" style="width:100%; height:100%;">
     <asp:ScriptManager id="ScriptManager1" runat="server" />
     <rsweb:ReportViewer SizeToReportContent="false" AsyncRendering="true" Height="100%" Width="100%" Style="display: table !important; margin: 0px; overflow: auto !important; min-height:500px;" ID="ReportViewer" runat="server" ProcessingMode="Remote"/>
    /form>
    

    Anyone know why the AsyncWait dialog is not being displayed for me?

    Thanks,

    Theo

    Wednesday, March 16, 2011 4:57 PM
  • Hello,

    I added a ReportViewer control to my ASP.NET app and everything seems to be working fine except that the spinning wheel icon that is supposed to pop up as you are waiting for the report to render does not get displayed.

    I'm using VS2008 and version 9.0.0.0 of Microsoft.Reporting.Webforms.

    This is the control markup:

    <form id="form1" runat="server">
    
     <div>
    
    	<rsweb:ReportViewer ID="ReportViewer1" ProcessingMode="Remote" AsyncRendering="false" SizeToReportContent="true" runat="server">
    
    	</rsweb:ReportViewer>
    
    
    
     </div>
    
    </form>
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    

    Any help would be appreciated! 

    Yes, you need to set AsyncRendering to "true" to get the spinning control. You don't need the ScriptManager because the VS2008 ReportViewer control is not an AJAX control (the VS2010 control is).
    Cephas Lin This posting is provided "AS IS" with no warranties.
    Thursday, March 17, 2011 3:43 PM
    Moderator
  • Hi,

    I am getting the same issue with Report viewer 2010 SP1.  However, I noticed in your example you have AsyncRendering set to false.  Have you tried changing this to true and adding a ScriptManager?

    In my case the style attribute display: is set to none. Setting this to inline whilst debugging forces the item to display.

    <form id="report_render_result" runat="server" style="width:100%; height:100%;">
    
     <asp:ScriptManager id="ScriptManager1" runat="server" />
    
     <rsweb:ReportViewer SizeToReportContent="false" AsyncRendering="true" Height="100%" Width="100%" Style="display: table !important; margin: 0px; overflow: auto !important; min-height:500px;" ID="ReportViewer" runat="server" ProcessingMode="Remote"/>
    
    /form>
    
    

    Anyone know why the AsyncWait dialog is not being displayed for me?

    Thanks,

    Theo

    Where's your code that hooks up the local/server report? There will be no spinning control if you don't try to hook up a report.
    Cephas Lin This posting is provided "AS IS" with no warranties.
    Thursday, March 17, 2011 3:44 PM
    Moderator
  • Hi Cephas,

    Thanks for the reply.

    The report displayed by the ReportViewer is setup in the code behind.

    The report render successfully but I don't get the AyncWait dialog.  The reports I am running are long enough for the timeout to kick in.

     // ReportViewer uses post backs to render the report, so make sure we don't
    
    // perform the initialisation in this case.
    
    if (IsPostBack) {
    
     return;
    
    }
    
    
    
    ReportViewer.PromptAreaCollapsed = true;
    
    ReportViewer.ShowCredentialPrompts = false;
    
    ReportViewer.ShowParameterPrompts = false;
    
    ReportViewer.ProcessingMode = ProcessingMode.Remote;
    
    ReportViewer.PageCountMode = PageCountMode.Actual;
    
    ReportViewer.ShowWaitControlCancelLink = true;
    
    ReportViewer.WaitControlDisplayAfter = 100;
    
    
    
    ReportViewer.ServerReport.DisplayName = Model.ReportDisplayName;
    
    ReportViewer.ServerReport.ReportPath = Model.SubFolder + "/" + Model.ReportName;
    
    ReportViewer.ServerReport.ReportServerUrl = new Uri(Configuration.MSRS_ReportServerBaseURL);
    
    ReportViewer.ServerReport.SetDataSourceCredentials(credentials);
    
    ReportViewer.ServerReport.SetParameters(parameters);
    
    
    
    

     

    Wednesday, March 23, 2011 8:39 AM
  • Not sure why you don't get the wait control. I tried your ASPX snippet with your code behind - less SetDataSourceCredentials and SetParameters (I assume you place it in Page_Load), and the wait control shows up just fine.

    See the behavior of WaitControlDisplayAfter at http://msdn.microsoft.com/en-us/library/ee344971.aspx. The first time the page loads, the wait control will always be displayed immediately on the async postback, so you should be able to see the wait control regardless.


    Cephas Lin This posting is provided "AS IS" with no warranties.
    Thursday, March 24, 2011 5:48 PM
    Moderator
  • You are right the WaitControlDisplayAfter is superfluous, I'd starting trying random things to see if they helped!

    The odd thing is that the wait control is on the form, but hidden, so whatever is supposed to display it is not being invoked.  I have tried in IE 8, IE9, Firefox and Chrome.  Same in all of them.

    It's frustrating as I was hoping to get the wait dialog displayed as some of our reports take a while to render (especially the first one).

    Theo

     

    • Proposed as answer by Theo Harper Friday, April 1, 2011 3:28 PM
    • Unproposed as answer by Theo Harper Friday, April 1, 2011 3:28 PM
    Thursday, March 24, 2011 10:47 PM
  • Eventually I stumbled across the answer, I found the following element in my web.config:

    <xhtmlConformance mode="Legacy"/> 

    Having this set to Legacy causes issues with AJAX controls, removing the entry or chaning to Strict fixes my problem.

    Theo

    • Proposed as answer by Theo Harper Friday, April 1, 2011 3:33 PM
    Friday, April 1, 2011 3:31 PM
  • Hi,

    It's an old thread, but I had this same issue with ReportViewer 10.

    The solution for me was to set EnablePartialRendering="true" in the script manager on the page.

    KingNugget

    Friday, June 15, 2012 2:18 PM
  • I did that, and while it did make the spinning wheel show up, the paging no longer worked.
    Tuesday, September 3, 2013 10:25 PM