locked
Cannot RDP to VM RRS feed

  • Question

  • Hi

    I'm trying to use a VM in Azure which I created by uploading a VHD file, but I cannot connect to the VM through RDP.

    These are the steps I followed:

    1) Created a VM locally using Hyper-V (Windows 8.1)

    2) Made sure it was possible to RDP to it (remote desktop enabled, port 3389 open in the firewal for inbound traffic, ...). From my local PC I can RDP to this VM

    3) Converted the VHDX to VHD using a powershell command

    4) Uploaded the VHD file to an Azure blob

    5) Created a disk in Azure from the VHD file indicating it ran a Windows OS (Note: I created a disk and not an image because I did not generalize the VM, nor did I run sysprep - I also don't want to create further VM's from this VHD file...)

    6) Created the VM from the disk. I left the default settings untouched, ie, I have 2 endpoints configured: powershell and remote desktop

    However, if I try the "connect command" from the Azure portal, I cannot RDP to the VM. I tried changing the public port of remote desktop to 3389 (read somewhere it could help...), restarted the VM, but all with no luck.

    Is there something else I'm missing?

    Thanks for your help

    Bruno

    Monday, February 17, 2014 7:03 AM

Answers

All replies