none
port number on windows 8 RRS feed

  • Question

  • Hi

    How to know which port number my process using on windows 8. I tried in command prompt by entering netstat -a . then it listed all tcp and Udp , BUT NOT HTTP. I am learning WCf and in APP.config file I have to enter baseaddress. I do not understand which http address I have to enter.I entered the address which I found when I used netstat -a in command prompt and it was giving me error saying that HTTP could not register at that URL....

    How to know HTTP where it is registered?



    • Edited by sr2011 Saturday, January 11, 2014 2:59 PM
    • Moved by Amanda Zhu Monday, January 13, 2014 6:38 AM
    Saturday, January 11, 2014 2:31 PM

Answers

  • Hi,

    By default the http will use port number 80, if you want to use others, please try to edit in the IIS:

    For the error: HTTP could not register at that URL, you can enable the wcf tracing to find the cause.
    #How to enable the wcf tracing:
    http://msdn.microsoft.com/en-us/library/ms733025(v=vs.110).aspx .

    Also it will better if you can post your configure file here.

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 17, 2014 10:27 AM
    Moderator

All replies

  • Hi,

    I have moved this thread to Windows Communication Foundation, Serialization, and Networking forum for better response because Visual Studio Geneal Questions forum mainly discusses the usage issues of VS IDE.

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, January 13, 2014 6:39 AM
  • Hi,

    By default the http will use port number 80, if you want to use others, please try to edit in the IIS:

    For the error: HTTP could not register at that URL, you can enable the wcf tracing to find the cause.
    #How to enable the wcf tracing:
    http://msdn.microsoft.com/en-us/library/ms733025(v=vs.110).aspx .

    Also it will better if you can post your configure file here.

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 17, 2014 10:27 AM
    Moderator
  • Thank you Amy for the reply. I will get back to you again.
    Friday, January 17, 2014 3:55 PM
  • Hi amy,

     when I run the project it says service is running. But when I try to test it I created web application and add service reference when I gave the address where service is located it won't give the service.

    Wednesday, January 22, 2014 4:17 PM