none
System.Data.OleDb.OleDbException: Unspecified error - while accessing MS-Access RRS feed

  • Question

  •  

    Hi,

     

    In my application, I'm accessing MS-Access DB via ASP.Net.

    Most of the times, I can access it; but sometimes I'm getting this error:

     

    System.Data.OleDb.OleDbException: Unspecified error

     

    After restarting the IIS, this issue got solved.

     

    Also, I tried the microsoft support - http://support.microsoft.com/kb/825738

    But I could not figure out the folder path given there - Document and Settings\ServerName\ASPNET\Local settings

     

    I'm using Window 2003 Server, ASP.NET 2.0

     

    If someone solved this issue, kindly let me know how to.

     

     

    Thanks in advance,

    Vikiboye

    Friday, November 9, 2007 12:39 PM

Answers

All replies

  • The article doesn't apply to ASP.NET 2.0, that's why you don't find the folder spcified.

     

    We also suffer from the similar problem (but in ASP.NET 1.1). However, the solution is still not found.

     

    Sunday, November 18, 2007 9:51 PM
  • It's not a good idea to try to share JET/Access via IIS in an ASP or ASP.NET application. The engine was simply not designed for this use. It's only able to handle one operation at a time and while it might appear to work in testing, it frequently fails in production under a load. We suggest using SQL Server Express instead.

    Sunday, November 18, 2007 10:31 PM
  • I'm sorry.  That is an unacceptable response.  I have been using MS-Access databases on .net websites for a few years now receiving thousands of server hits per month with no notice of failures.

     

    I am running my website on a production web server now.  I have recently purchased a new PC with Windows Vista Home Premium installed.  I have installed Visual Studio 2005 Standard Edition, have had to install the fixpatch to overcome the debugging problem because VS2005 expects Integrated Windows Authentication and Home Premium does not support it, but I now cannot get past the above problem.  It does not happen occasionally, it is constant.  My aspx pages render in localhost just fine, but as soon as I attempt to open a page which has a call to my Access database, the failure occurs, both in debug mode and by invoking the app directly from my browser.

     

    What is most frustrating is I can use the features in Visual Studio 2005 to connect to my database, configure and successfully test a query, but as soon as I try to run the page, it blows up with System.Data.OleDb.OleDbException: Unspecified Error.

     

    Has anyone managed to get this configuration to work?

     

    Tuesday, November 20, 2007 7:03 AM
  • It appears that my specific problem was with IIS 7.0 on Windows Vista.  The following blog explained and provided a solution for me.

    http://blogs.iis.net/bills/archive/2007/05/21/tips-for-classic-asp-developers-on-iis7.aspx

     

     

    Thursday, November 22, 2007 3:23 PM