locked
Configureation Error - Theme not found? RRS feed

  • Question

  • User-1683467489 posted

    I have all the files in place?

     

    <title>Configuration Error</title><style> body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px} b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px} H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red } H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon } pre {font-family:"Lucida Console";font-size: .9em} .marker {font-weight: bold; color: black;text-decoration: none;} .version {color: gray;} .error {margin-bottom: 10px;} .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; } </style>

    Server Error in '/Admin' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Theme 'Red' cannot be found in the application or global theme directories.

    Source Error:

    [No relevant source lines]

    Source File: d:\hosting\krumreiwood\web.config    Line: 49


    Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433
    <!-- [ConfigurationErrorsException]: Theme 'Red' cannot be found in the application or global theme directories. (d:\hosting\krumreiwood\web.config line 49) at System.Web.Configuration.PagesSection.get_StyleSheetThemeInternal() at System.Web.UI.PageParser.ProcessConfigSettings() at System.Web.UI.TemplateParser.PrepareParse() at System.Web.UI.TemplateParser.Parse() at System.Web.Compilation.BaseTemplateBuildProvider.get_CodeCompilerType() at System.Web.Compilation.BuildProvider.GetCompilerTypeFromBuildProvider(BuildProvider buildProvider) at System.Web.Compilation.BuildProvidersCompiler.ProcessBuildProviders() at System.Web.Compilation.BuildProvidersCompiler.PerformBuild() at System.Web.Compilation.BuildManager.CompileWebFile(VirtualPath virtualPath) at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile) at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean noAssert) at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp, Boolean noAssert) at System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) at System.Web.UI.PageHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) at System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, VirtualPath path, String pathTranslated, Boolean useAppConfig) at System.Web.HttpApplication.MapHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) --><!-- This error page might contain sensitive information because ASP.NET is configured to show verbose error messages using <customErrors mode="Off"/>. Consider using <customErrors mode="On"/> or <customErrors mode="RemoteOnly"/> in production environments.--> 

    Saturday, January 31, 2009 7:04 PM

All replies

  • User730446648 posted

    It's saying that your web.config has your theme set as Red.

    And it looks for the Red Folder like this.

    App_Themes/Red/Default.css
    And there should  be an Images folder inside the Red folder like so.

    App_Themes/Red/Images

    You probably deleted, or changed the spelling of something.
    Check it out.

    Good Luck

    - Daniel

     

    Saturday, January 31, 2009 10:23 PM
  • User-1683467489 posted

    Thanks for the reply!

    I checked and all the files are loaded in the App_Theme folder along with all the Default.css file.

     I even re-uploaded the entire App_Theme folder, still get that error.

     

    If all else fails, I may have to dump, and reload the entire site again.  urg, thanks again for all your help!

     

     

    Paul

    Sunday, February 1, 2009 11:44 AM
  • User730446648 posted

    Do you get the error on your local computer?

    Before you reupload everything try uploading the original admin files.
    I saw something that says Admin in your error. 

    What's your web address?
    And what specific page is causing the error, or is it all of them?

    I might see your issue.
    I'll take a look if you want.

    Sunday, February 1, 2009 12:12 PM
  • User730446648 posted

    Or maybe you made an error in the default.css file.

    Assuming that you still have theme folder named Blue,
    In your web.config try changing your default theme from Red to Blue.

    Capitalization is important, make sure the spelling is exactly like the folder name.

    Sunday, February 1, 2009 12:19 PM
  • User-1683467489 posted

     www.woodshoppers.com

     You can login as admin and try it.

    krumrei22

    Coolman22!  Pass.

    I will change it later.  :)

     

     

     

    Sunday, February 1, 2009 2:13 PM
  • User-1683467489 posted

     I just tried to change the web.config file to "Blue" still same error.  :(

    Sunday, February 1, 2009 2:17 PM
  • User-1683467489 posted

    I also noticed I get this error in VB 2008

     

    Message 1 Could not find schema information for the element 'http://schemas.microsoft.com/.NetConfiguration/v2.0:configuration'. C:\Users\paul\Documents\Visual Studio 2008\Templates\ProjectTemplates\Visual Web Developer\VisualBasic\web.config 2 2 Miscellaneous Files

     

     

    Sunday, February 1, 2009 2:20 PM
  • User730446648 posted

    That's very weird that it only has problems in Admin.

    Since it's trying to make me log back in I think the problem's in your web.config

    Let's see your web.config.

    Don't forget to xxxxx out you user name and passwords in the connection strings.

     

    Here's another thought, rename the Admin folder to anything else.
    This will make it not require the user to be logged in.

    And now can you view those files, maybe??
    Report back.

     

    Sunday, February 1, 2009 2:59 PM
  • User-1683467489 posted
    ?xml version="1.0"?>

    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

    <configSections>

    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">

    <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">

    <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>

    <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">

    <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>

    <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>

    <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>

    <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/></sectionGroup></sectionGroup></sectionGroup></configSections><location path="Admin">

    <system.web>

    <authorization>

    <allow roles="Administrators"/>

    <deny users="*"/>

    </authorization>

    </system.web>

    </location>

    <location path="PostAd.aspx">

    <system.web>

    <authorization>

    <deny users="?"/>

    </authorization>

    </system.web>

    </location>

    <location path="EditPhotos.aspx">

    <system.web>

    <authorization>

    <deny users="?"/>

    </authorization>

    </system.web>

    </location>

    <location path="MyAds.aspx">

    <system.web>

    <authorization>

    <deny users="?"/>

    </authorization>

    </system.web>

    </location>

    <location path="MyProfile.aspx">

    <system.web>

    <authorization>

    <deny users="?"/>

    </authorization>

    </system.web>

    </location>

    <system.web>

    <customErrors mode="Off"/>

    <pages styleSheetTheme="Blue">

    <controls>

    <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></controls></pages>

    <authentication mode="Forms"/>

    <membership>

    <providers>

    <clear/>

    <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="LocalSqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" applicationName="/" requiresUniqueEmail="true" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="1" passwordAttemptWindow="10" passwordStrengthRegularExpression=""/>

    </providers>

    </membership>

    <profile enabled="true">

    <properties>

    <add name="FirstName" type="System.String"/>

    <add name="LastName" type="System.String"/>

    <add name="MemberId" defaultValue="0" type="System.Int32"/>

    <group name="Core"/>

    </properties>

    </profile>

    <roleManager enabled="true"/>

    <compilation debug="true" urlLinePragmas="true">

    <assemblies>

    <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

    <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

    <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/></assemblies></compilation>

    <siteMap defaultProvider="RoleEnabled_AspNetXmlSiteMapProvider" enabled="true">

    <providers>

    <clear/>

    <add name="RoleEnabled_AspNetXmlSiteMapProvider" type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" siteMapFile="web.sitemap" securityTrimmingEnabled="true"/>

    </providers>

    </siteMap>

    <httpHandlers>

    <remove verb="*" path="*.asmx"/>

    <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    <add verb="GET,HEAD" path="ScriptResource.axd" validate="false" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></httpHandlers>

    <httpModules>

    <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></httpModules></system.web>

    <connectionStrings>

    <add name="classifiedsConnection" connectionString="Data Source=woodshoppers.db.3415754.hostedresource.com; Initial Catalog=XXXXXXX; User ID=XXXXXXX; Password=XXXXXXX ;"/>

    <remove name="LocalSqlServer"/>

    <add name="LocalSqlServer" connectionString="Data Source=woodshoppers.db.3415754.hostedresource.com; Initial Catalog=XXXXXXX; User ID=XXXXXXX; Password=XXXXXXX ;"/>

    </connectionStrings>

    <system.net>

    <mailSettings>

    <smtp>

    <network host="yourSMTPhostname" port="25" defaultCredentials="true" userName="enterUserNameHereIfRequired" password="enterPasswordIfRequired"/>

    /&gt;

    </smtp>

    </mailSettings>

    </system.net>

    <system.codedom>

    <compilers>

    <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CSharp.CSharpCodeProvider,System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">

    <providerOption name="CompilerVersion" value="v3.5"/>

    <providerOption name="WarnAsError" value="false"/></compiler>

    <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">

    <providerOption name="CompilerVersion" value="v3.5"/>

    <providerOption name="OptionInfer" value="true"/>

    <providerOption name="WarnAsError" value="false"/></compiler></compilers></system.codedom>

    <system.webServer>

    <validation validateIntegratedModeConfiguration="false"/>

    <modules>

    <remove name="ScriptModule"/>

    <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></modules>

    <handlers>

    <remove name="WebServiceHandlerFactory-Integrated"/>

    <remove name="ScriptHandlerFactory"/>

    <remove name="ScriptHandlerFactoryAppServices"/>

    <remove name="ScriptResource"/>

    <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    <add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/></handlers></system.webServer>

    <runtime>

    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">

    <dependentAssembly>

    <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>

    <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/></dependentAssembly>

    <dependentAssembly>

    <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>

    <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/></dependentAssembly></assemblyBinding></runtime></configuration>

    Sunday, February 1, 2009 5:20 PM
  • User730446648 posted

    Sorry, but I just don't see the problem.

    Does it work on your local computer?
    Did you try renaming the admin folder?

    Sunday, February 1, 2009 8:56 PM
  • User-1683467489 posted

    Ok, so I dumped everything, recompiled it, published it to the site.

    Ran the SQl scripts, everything is working.

    I changed my user id role to a Admin role.

     I login to the site, then I get this error message now.

    http://woodshoppers.com/Off?aspxerrorpath=/Admin/login.aspx

    I even added the Login.ASPX file and the vb file to the folder too.

     

     

     

    Sunday, February 1, 2009 11:18 PM
  • User730446648 posted

    Maybe there's something with the way you're compiling it.

    I host with godaddy, and the links are coming back odd.
    It shouldn't say Off.

    If you try to go into my Admin section without logging in I get,
    http://www.detelli.com/login.aspx?ReturnUrl=%2fadmin%2fdefault.aspx

    And if I force an error I get,
    http://www.detelli.com/Error.aspx?aspxerrorpath=/Adminn/fghjk.aspx

    Unless your web.config error page is Off

    But I bet you didn't set your web.config like you did before.
    <customErrors mode="Off"/>

    It might be nothing but I have never seen this tag in your web.config.
    urlLinePragmas

    Monday, February 2, 2009 12:42 AM
  • User-1683467489 posted

     I fixed the web config....I noticed however it is giving me an error message in VB 2008 about this. <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

    Message    1    Could not find schema information for the element 'http://schemas.microsoft.com/.NetConfiguration/v2.0:configuration'.    ftp://ftp.woodshoppers.com/web.config    2    2   
     

    Monday, February 2, 2009 9:03 AM
  • User-1683467489 posted

     Let me run down step by step what I am doing, maybe it is my process?

    1. Setup SQL server on Godaddy

    2. Open the website on my local PC using VB2008.

    3. Change the webconfig file to the connection string and save the file locally.

    4. Build the site locally.

    5. Publish the site to the FTP server.

    6. Run the add and catagory .SQL's on the SQL server.

    7. Create a user on the site.

    8. Go to the SQL server, find the ROLE ID on the SQL and change my user to an Admin RoleID.

     

     

     

    Monday, February 2, 2009 10:42 AM
  • User-1683467489 posted

    Ok,

     

    I reloaded the entire site.  I can switch colors in the webconfig file now to Blue, Green or Red.

    Now, when I login as an admin, click on Site Admin, this is what I get.

     

    Server Error in '/Admin' Application.

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /Admin/login.aspx


    Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

    Monday, February 2, 2009 3:17 PM