locked
[EWS Java API 1.1.5] Cannot send email with EWS Java API RRS feed

  • Question

  • i am using EWS to send emails on Exchange 2010
    as follows:

               
    ExchangeService service = new ExchangeService();    		ExchangeCredentials credentials = new WebCredentials(email, password);    		service.setCredentials(credentials);    		service.setUrl(new java.net.URI("https://" + host    				+ "/EWS/Exchange.asmx"));    		service.setTraceEnabled(true);                EmailMessage msg = new EmailMessage(service);    		msg.setSubject("Hello world!");    		msg.setBody(MessageBody    				.getMessageBodyFromText("Sent using the EWS Managed API."));    		msg.getToRecipients().add("email");    		msg.send();



    the message is not delivered to the inbox, and i don't know what is the problem.
    after i enabled tracing, i get the following :


     
       <Trace Tag="EwsRequestHttpHeaders" Tid="1" Time="2012-10-14 11:13:46Z">    POST /EWS/Exchange.asmx HTTP/1.1    Content-type : text/xml; charset=utf-8    Accept-Encoding : gzip,deflate    Keep-Alive : 300    User-Agent : ExchangeServicesClient/0.0.0.0    Connection : Keep-Alive    Accept : text/xml            </Trace>        <Trace Tag="EwsRequest" Tid="1" Time="2012-10-14 11:13:47Z">    <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:m="http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types"><soap:Header><t:RequestServerVersion Version="Exchange2010_SP1"></t:RequestServerVersion></soap:Header><soap:Body><m:CreateItem MessageDisposition="SendOnly"><m:Items><t:Message><t:Subject>Hello world!</t:Subject><t:Body BodyType="HTML">Sent using the EWS Managed API.</t:Body><t:ToRecipients><t:Mailbox><t:EmailAddress>adamb@fabrikam.com</t:EmailAddress></t:Mailbox></t:ToRecipients></t:Message></m:Items></m:CreateItem></soap:Body></soap:Envelope>    </Trace>        14/10/2012 01:13:48 م org.apache.commons.httpclient.auth.AuthChallengeProcessor selectAuthScheme    INFO: NTLM authentication scheme selected    <Trace Tag="EwsResponseHttpHeaders" Tid="1" Time="2012-10-14 11:13:48Z">    200 text/xml; charset=utf-8    X-AspNet-Version : 2.0.50727    X-EwsPerformanceData : RpcC=3;RpcL=15;LdapC=0;LdapL=0;    Persistent-Auth : true    Date : Sun, 14 Oct 2012 11:13:48 GMT    Vary : Accept-Encoding    Transfer-Encoding : chunked    Content-Encoding : gzip    Content-Type : text/xml; charset=utf-8    X-Powered-By : ASP.NET    Server : Microsoft-IIS/7.5    Cache-Control : private            </Trace>        <Trace Tag="EwsResponse" Tid="1" Time="2012-10-14 11:13:48Z">    <?xml version="1.0" encoding="utf-8"?><s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Header><h:ServerVersionInfo MajorVersion="14" MinorVersion="1" MajorBuildNumber="218" MinorBuildNumber="14" Version="Exchange2010_SP1" xmlns:h="http://schemas.microsoft.com/exchange/services/2006/types" xmlns="http://schemas.microsoft.com/exchange/services/2006/types" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"/></s:Header><s:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><m:CreateItemResponse xmlns:m="http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types"><m:ResponseMessages><m:CreateItemResponseMessage ResponseClass="Success"><m:ResponseCode>NoError</m:ResponseCode><m:Items/></m:CreateItemResponseMessage></m:ResponseMessages></m:CreateItemResponse></s:Body></s:Envelope>    </Trace>



    please advise how to solve this issue.

    • Edited by DevMsaleh Sunday, October 14, 2012 3:28 PM
    Sunday, October 14, 2012 12:55 PM

All replies