locked
Asp.net cannot post back to server RRS feed

  • Question

  • User-1453258508 posted

    Hi,

     We recently encountered a problem where the server is rejecting all requests that are asp.net post backs. the site will load initially, but any button click event or post back event will display a error in the brower. it is not an asp.net type error but browser error.

    Internet Explorer "Internet Explorer cannot display the web page"

    Mozilla "The connection was reset.

    The connection to the server was reset while the page was loading."

    The browser errors are always displayed immediately with no wait time ruling Timeouts are not the issue. I started to log every request in the Global_BeginRequest method in the global.asax file and confirmed that the application is not even being hit during these postbacks.

    The error started to occur when the sysadmin install 4 updates. They are

    - Update for Windows Server 2003 (KB973917)

    - Windows Malicious Software Removal Tool - March 2010 (KB890830)

    - Update for Windows Server 2003 (KB979306)

    - Cumulative Security Update for Internet Explorer 6 for Windows Server 2003 (KB980182)

    Besides the above mentioned updates, I don't know what changed that may cause all post backs to be refused. Any help much appreciated.

    Thanks.

     

    PS: The company does not want to uninstall the updates or do a system restore as there are several web sites being hosted on the server.

    Tuesday, April 13, 2010 4:50 PM

All replies

  • User236141260 posted

    Run aspnet_regiss.exe command, this will reset dotnet compatibility with iis.

    Wednesday, April 14, 2010 1:27 AM
  • User-1011786642 posted

    Is service pack 2 installed on your system?

    Here it says that it is required for KB973917: http://www.microsoft.com/downloads/details.aspx?FamilyId=98b55fff-061a-4050-92c4-661177ebfe6d&displaylang=en

    Check this too - it has similar problem after installing this update: http://forums.asp.net/t/1502579.aspx

    Regards,

    Night_dog

    Wednesday, April 14, 2010 2:25 AM
  • User-1453258508 posted

    Is there any way to solve this error without uninstalling the update or reinstalling service pack 2.

    This server hosts several live web sites that cannot be disrupted. Basically, I want a very smooth and

    easy solution. I know uninstalling the update would do the job, but boss doesn't like that solution ... i know i know, tell me about it.

    Anyways, any help appreciated.

    Thanks. 

    Wednesday, April 14, 2010 9:49 AM
  • User-37275327 posted

    Repaire your dotnetframework you have installed.


    Sunday, April 18, 2010 1:14 AM