locked
"The SPListItem being updated was not retrieved with all taxonomy fields." exception when adding a wiki page RRS feed

  • Question

  • i am working on an enterprise wiki site collection inside SP2013. currently when a user try to add a wiki page , and he leave a mandatory field empty , he will be redirected to the following page:-

    and when he fills all the required fields he will get the following exception:-

    The SPListItem being updated was not retrieved with all taxonomy fields.

    baring in mind that if the user from the beginning enter all the required field inside the enterpriseWiki page layout he can save his page without any problems ? can anyone adivce . i check the List View Lookup Threshold and i set it to 1000!! but this did not solve the problem ?

    please can anyone advice ?

    Thanks

    Thursday, September 4, 2014 11:53 AM

Answers

  • i am working on an enterprise wiki site collection inside SP2013. currently when a user try to add a wiki page , and he leave a mandatory field empty , he will be redirected to the following page:-

    and when he fills all the required fields he will get the following exception:-

    The SPListItem being updated was not retrieved with all taxonomy fields.

    baring in mind that if the user from the beginning enter all the required field inside the enterpriseWiki page layout he can save his page without any problems ? can anyone adivce . i check the List View Lookup Threshold and i set it to 1000!! but this did not solve the problem ?

    please can anyone advice ?

    Thanks


    I have applied the SP CU for September 2014 on my sharePoint server, and after that users will not be redirected to the page causing the problem. finally i got it working !!
    • Marked as answer by johnjohn11 Thursday, September 11, 2014 10:35 AM
    Thursday, September 11, 2014 10:35 AM

All replies