none
After Updating to Visual Studio 2017 version 15.0.26403.0, Create App Packages for UWP Failed

    Question

  • When I have Visual Studio 2017 version 15.0.26228.10, creating app packages for UWP works just fine. After updating to version 15.0.26403.0, I get the following error message when trying to create the same app package:

    Severity Code Description Project File Line Suppression State
    Error File 'C:\Work\EzPodder.Universal.1607_v2.6.3\EzPodder\bin\ARM\Release\EzPodder_2.6.3.0_language-zh-hans.appx' not found. EzPodder

    Thursday, April 06, 2017 2:34 AM

Answers

  • I found a potential workaround from the VS 2017 team.  They have hotfix that also solve the issue using my local repro.

    Open Visual Studio, clock on the feedback Icon (Upper Right next to the search box), select "Report a problem".  This will start Visual Studio Feedback App.  Search for "Error: File 'C:\somepath\bin\ARM\Release\App_1.1.218.0_scale-100.appx' not found."

    In the solution section you will see instruction to download storepackageworkaround.zip.  Follow those instruction to fix the language package issue.

    Thanks,
    Cameron

    • Marked as answer by Weidong Shen Friday, April 14, 2017 4:04 PM
    Thursday, April 13, 2017 11:35 PM

All replies

  • Hello weidong,

    Thanks for posting here.

    I have created app packages for UWP on Visual Studio Professional 2017 version 15.0.26228.10 and 15.0.26403.0 successfully without any error. So please try to create a Blank App project without any other modification, then create app packages for UWP, check if it works fine. If yes, this error should be related to your project, you nee to check your the difference of project files which created with different versions of Visual Studio.

    If this issue is still persist in the blank App project, could you please provide us some more detail steps to reproduce this issue.

    Hope this can help you.


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Thursday, April 06, 2017 9:16 AM
  • Hello Leo,

    First of all, make sure you create app package for UWP on Visual Studio 2017 version 15.1.26403.0, not version 15.0.26228.10.

    Here is a link for a blank app I created: https://1drv.ms/u/s!Au_B0YcF-gJggegLY1zbU8zc2FxXzA

    First, associate the app with the store, and then try to create app package.

    Thanks,

    Weidong Shen

    Thursday, April 06, 2017 6:30 PM
  • @Weidong, yes, I`m sure I create app package for UWP on Visual Studio 2017 version 15.1.26403.0. But the different is that My test app does not contain MultilingualResources. You can create a new blank app without MultilingualResources, check if it works fine? If yes, that should be Multilingual app toolkit is incompatible with latest Visual Studio 2017, you can submit a user voice here:https://multilingualapptoolkit.uservoice.com/


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Weidong Shen Friday, April 07, 2017 5:05 PM
    • Unmarked as answer by Weidong Shen Friday, April 14, 2017 3:52 PM
    Friday, April 07, 2017 10:45 AM
  • Thanks. I will contact them instead.
    Friday, April 07, 2017 5:05 PM
  • This does not appear to be an issue with the Multilingual App Toolkit. 

    I created a project with a source culture of en-US and a target of zh-Hans.  I created all cultures manually - with out the use of MAT or any other tooling.  When I select Project->Store->Create app packages, the appx is created successfully. 

    However, when I add a second target language of zh-Hant (in this test), selecting Project->Store->Create app packages results in the reported error.

    1>------ Build started: Project: NoMat, Configuration: Debug ARM ------
    1>  NoMat -> ...\\visual studio 2017\Projects\MAT\VS2017\AppxNotFound\NoMat\bin\ARM\Debug\NoMat.exe
    1>  NoMat -> ...\\visual studio 2017\Projects\MAT\VS2017\AppxNotFound\NoMat\bin\ARM\Debug\NoMat_1.0.11.0_ARM_Debug.appx
    1>  NoMat -> ...\\visual studio 2017\Projects\MAT\VS2017\AppxNotFound\NoMat\AppPackages\NoMat_1.0.11.0_Debug_Test\NoMat_1.0.11.0_ARM_Debug.appxsym
    1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\MSBuild\Microsoft\VisualStudio\v15.0\AppxPackage\Microsoft.AppXPackage.Targets(3899,5): error APPX0502: File '...\\visual studio 2017\Projects\MAT\VS2017\AppxNotFound\NoMat\bin\ARM\Debug\NoMat_1.0.11.0_language-zh-hans.appx' not found.
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
    ========== Package: 0 succeeded, 1 failed ===========

    As an additional test, I added a third target culture - es-ES. This time selecting Project->Store->Create app packages resulted in the same error but on a different culture.

    1>------ Build started: Project: NoMat, Configuration: Debug ARM ------
    1>  NoMat -> ...\\visual studio 2017\Projects\MAT\VS2017\AppxNotFound\NoMat\bin\ARM\Debug\NoMat.exe
    1>  NoMat -> ...\\visual studio 2017\Projects\MAT\VS2017\AppxNotFound\NoMat\bin\ARM\Debug\NoMat_1.0.10.0_ARM_Debug.appx
    1>  NoMat -> ...\\visual studio 2017\Projects\MAT\VS2017\AppxNotFound\NoMat\AppPackages\NoMat_1.0.10.0_Debug_Test\NoMat_1.0.10.0_ARM_Debug.appxsym
    1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\MSBuild\Microsoft\VisualStudio\v15.0\AppxPackage\Microsoft.AppXPackage.Targets(3899,5): error APPX0502: File '...\\visual studio 2017\Projects\MAT\VS2017\AppxNotFound\NoMat\bin\ARM\Debug\NoMat_1.0.10.0_language-es.appx' not found.
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
    ========== Package: 0 succeeded, 1 failed ===========

    Since the error is consistent with two or more target cultures using a new project without the use of the Multilingual App Toolkit, the problem is with Visual Studio 2017, specifically when publishing for ARM.

    Environment: Windows 10, Visual Studio 2017 Version 15.1 (26403.3)

    Workaround: Setting "Generate app bundle" to Never will allow the successfully creation of the ARM Appx.  This does disable the resource bundling functionality, which may or may not be acceptable for your scenario.

    Thank you,
    Cameron

    Thursday, April 13, 2017 3:04 PM
  • I found a potential workaround from the VS 2017 team.  They have hotfix that also solve the issue using my local repro.

    Open Visual Studio, clock on the feedback Icon (Upper Right next to the search box), select "Report a problem".  This will start Visual Studio Feedback App.  Search for "Error: File 'C:\somepath\bin\ARM\Release\App_1.1.218.0_scale-100.appx' not found."

    In the solution section you will see instruction to download storepackageworkaround.zip.  Follow those instruction to fix the language package issue.

    Thanks,
    Cameron

    • Marked as answer by Weidong Shen Friday, April 14, 2017 4:04 PM
    Thursday, April 13, 2017 11:35 PM
  • Thank you so much!
    Friday, April 14, 2017 4:05 PM