none
USB flash memory write caching RRS feed

  • Question

  • I've built 2 images: one on SP2/FP2007 and the other on
    SP2/FP2007/UpdateRollup1.  First runs on a AMD MB, second on an Intel.

    Now: my application writes a few files to a USB flash drive.  On the first
    image when the flash LED stops blinking I can remove it, plug it into a PC
    and my files are there.  On the second, after the initial flashing stops if
    I pull it out - no files.  If I leave it in, 20-30 seconds later there's
    more LED activity, then if I pull it my files are there.

    So: was write caching turned on in UR1, or is this a function of my
    hardware?  Are there registry entries that control this?

    If someone has any insight I'd be grateful.

    Thanks,
    Dean

     

    Thursday, June 5, 2008 7:39 PM

Answers

  • Problem solved: I inadvertently added a USB Boot component to my image, and
    doing so apparently changed the way XP treated USB drives.  Removing the
    component solved my problem.

    Thanks,
    Dean

     

    Friday, June 6, 2008 6:10 PM