The following forum(s) have migrated to Microsoft Q&A (Preview): Azure Active Directory!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
Adding API access to an Azure AD app registrations fails with connection error RRS feed

  • Question

  • When trying to add API access to an AAD app registration, a connection error occurs.

    Steps to repro:

    1. Create Web API registration in AAD
    2. Create Web app registration in AAD
    3. For this web app registration, from "Required permissions" try to add API access to the web API from step 1.
    4. A failure occurs and is reported in the notification

    

    Network traffic shows a 500 error and contains complete stack trace of server-side .NET implementation:

    Fragment:

    at Microsoft.ActiveDirectory.PortalExtension.ADExtension.Server.RegisteredApps.RegisteredApplicationsController.<UpdateApplication>d__27.MoveNext() in E:\bt\862925\repo\src\ADExtension\Extension\Server\RegisteredApps\RegisteredApplicationsController.cs:line 379
    ↵--- End of stack trace from previous location where exception was thrown ---
    ↵   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
    ↵   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
    ↵   at System.Threading.Tasks.TaskHelpersExtensions.<CastToObject>d__3`1.MoveNext()
    ↵--- End of stack trace from previous location where exception was thrown ---
    ↵   at 

    Wednesday, November 8, 2017 9:55 AM

Answers

  • There was a deployment issue last night that caused this issue. Could you try again. If this is still an issue for you, let us know for the further assistance.

    -------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you and vote it as helpful, this can be beneficial to other community members.  

    Wednesday, November 8, 2017 9:38 PM

All replies

  • There was a deployment issue last night that caused this issue. Could you try again. If this is still an issue for you, let us know for the further assistance.

    -------------------------------------------------------------------------------------------------------------
    Do click on "Mark as Answer" on the post that helps you and vote it as helpful, this can be beneficial to other community members.  

    Wednesday, November 8, 2017 9:38 PM
  • Thanks. All good now.
    Wednesday, December 13, 2017 10:38 AM
  • We are glad to know that.
    Wednesday, December 13, 2017 9:18 PM