none
How can I allow leading zeros for X12 GS06? RRS feed

  • Question

  • I have an agreement with "Preserve interchange - " for inbound batch processing option. I received the following message:

    Error: 1 (Field level error) SegmentID: GS Position in TS: 0 Data Element ID: GS06 Position in Segment: 6 Data Value: 000066468 6: Invalid character in data element

    I guess this must be caused by leading zeros for group control number. How can I allow this?

    Tuesday, December 21, 2010 3:30 AM

Answers

  • Hi Ptatssi,

    For allow leading zeros, you can configure it in

    Party-->EDI Property-->X12 Porperty-->Party Interchange Sender-->Validation and ACK Generation-->Checked Allow Leading and trailing  Zeros and spaces

    or

    Party-->EDI Property-->X12 Porperty-->Party Interchange Receiver-->Validation and ACK Processing-->Checked Allow Leading and trailing  Zeros and spaces.

    Then restart the instance.

    Tuesday, December 21, 2010 7:12 AM
  • Kim,

    Assume BizTalk Server is installed in PartyA, and PartyB Send EDI files to PartyA

    In The Agreement : PartyB -> PartyA Tab

    Under Transaction Set Settings   -> Validation Node

    Add the Transaction Type PartyA receives from PartyB and Enable Allow leading and trailing Zeroes and Spaces CheckBox for that Transaction.



    Sathish - http://blog.tsathish.com - Please Indicate "Mark as Answer" if this Post has Answered the Question
    Wednesday, December 22, 2010 1:46 AM

All replies

  • Hi Ptatssi,

    For allow leading zeros, you can configure it in

    Party-->EDI Property-->X12 Porperty-->Party Interchange Sender-->Validation and ACK Generation-->Checked Allow Leading and trailing  Zeros and spaces

    or

    Party-->EDI Property-->X12 Porperty-->Party Interchange Receiver-->Validation and ACK Processing-->Checked Allow Leading and trailing  Zeros and spaces.

    Then restart the instance.

    Tuesday, December 21, 2010 7:12 AM
  • Hi Sinosky.lin,

    I'm working with BTS 2010, but I'm not sure where I can find "Allow Leading and training Zeros and spaces". If you mean one in Transaction set settings in party's agreeement, it has no effect to GS06 by my testing.

    Thanks,


    PT Kim
    Wednesday, December 22, 2010 12:10 AM
  • Kim,

    Assume BizTalk Server is installed in PartyA, and PartyB Send EDI files to PartyA

    In The Agreement : PartyB -> PartyA Tab

    Under Transaction Set Settings   -> Validation Node

    Add the Transaction Type PartyA receives from PartyB and Enable Allow leading and trailing Zeroes and Spaces CheckBox for that Transaction.



    Sathish - http://blog.tsathish.com - Please Indicate "Mark as Answer" if this Post has Answered the Question
    Wednesday, December 22, 2010 1:46 AM
  • Hi Kim,

    Sorry. The configuration I posted is for BizTalk 2009.

    I think Sathish's post is for 2010.

    In BizTalk 2009, you have to restart the BizTalkServerApplication instance afthe update the party configuration. Not sure if it is necessary to to restart or not in BizTalk 2010.

    Thanks

    Sinosky

    Wednesday, December 22, 2010 7:00 AM