locked
FBWF and the System account rights RRS feed

  • Question

  • Good morning,

    I've got some issues with the FBWF in my Windows Embedded Standard 7 image.
    My system drive (C:) is protected by the FBWF. The installation and configuration goes well, but after enabling the FWBF and rebooting (using the FirstLogonCommands) there goes something wrong. The AutoLogon (with Administrator rights) works, but every application I try to start shows the "Open File Security Warning".

    After a lot of debugging I've figured out the System account was responsible for this.
    By default this account has no Administrator rights. If I change this by hand, the "Open File Security Warning" disappears.

    My question:
    Is assigning admin rights to the system account the only way to get around this?
    (And is there a way to script this?)

    Greetings from Holland,

    Peter

     

     

    Thursday, September 8, 2011 8:51 AM

Answers

All replies

  • FBWF isn't the issue. If FBWF is disable, you would get the same result. This sounds like Windows User Account Control (UAC). If you set EnableLUA to false in your answer file, the problem should go away.

    System acccount? Or do you mean a local account, where the Group setting is set to User?

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - ProGuide to WES 7, XP Embedded Advanced, WEPOS / POS for .NET Step-by-Step
    Thursday, September 8, 2011 3:58 PM
  • I had this same issue and found that it occurred after running windows update.  I would image the computer and run windows update to get the latest patches and then I would get this security warning on everything.  I tested it on a couple of machines and if I don't install the updates it functions fine.  I am not sure which specific update is the problem.
    Friday, September 9, 2011 8:44 PM
  • FBWF isn't the issue. If FBWF is disable, you would get the same result. This sounds like Windows User Account Control (UAC). If you set EnableLUA to false in your answer file, the problem should go away.

    System acccount? Or do you mean a local account, where the Group setting is set to User?

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - ProGuide to WES 7, XP Embedded Advanced, WEPOS / POS for .NET Step-by-Step

    I have to disagree on this one Sean, enabling or disabling UAC has no effect (tested multiple times).
    Only adding the system account to the administrator group did the trick. (see picture)

    Monday, September 12, 2011 4:06 PM
  • I had this same issue and found that it occurred after running windows update.  I would image the computer and run windows update to get the latest patches and then I would get this security warning on everything.  I tested it on a couple of machines and if I don't install the updates it functions fine.  I am not sure which specific update is the problem.

    Interesting, you might be right, I've downloaded all updates for the data share and included them into the image.
    Has someone an idea which update could cause this problem?

    Monday, September 12, 2011 4:10 PM
  • This is new. For clarification, what account are you autolog into? And what group is the account in? What type of applications were you trying to run?

    It would be nice to repeat the steps to see what is going on.

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - ProGuide to WES 7, XP Embedded Advanced, WEPOS / POS for .NET Step-by-Step
    Monday, September 12, 2011 4:45 PM
  • I'm pretty sure it was an update within the last 4-6 weeks, that caused the issue. I had downloaded all the updates into my DS and image up to about 4-6 weeks ago and then I have just been test various things sense then. It wasn't until i started checking for updates on my machines through Windows updates that I started getting the Open File Security Warning. 

    At first I though it was some changes I had made in my answer files, but after some more testing it is defiantly and update in the last 4-6 weeks that's causing the issue.

    Monday, September 12, 2011 7:12 PM
  • This is new. For clarification, what account are you autolog into? And what group is the account in? What type of applications were you trying to run?

    It would be nice to repeat the steps to see what is going on.

    -Sean


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - ProGuide to WES 7, XP Embedded Advanced, WEPOS / POS for .NET Step-by-Step
    Im setting up the useraccounts in pass 7 OBBE system (see picture).
    All applications (except my custom shell) raises the security warning. Even system applications like epxlorer.exe, dnotify.exe and control.exe.
    Maybe an important note, I'm using the DS64SP1 data share.


    Tuesday, September 13, 2011 6:23 AM
  • I'm pretty sure it was an update within the last 4-6 weeks, that caused the issue. I had downloaded all the updates into my DS and image up to about 4-6 weeks ago and then I have just been test various things sense then. It wasn't until i started checking for updates on my machines through Windows updates that I started getting the Open File Security Warning. 

    At first I though it was some changes I had made in my answer files, but after some more testing it is defiantly and update in the last 4-6 weeks that's causing the issue.

    It's one of the updates provided on 08/16/2011 02:00.
    I'm still testing which one is responsible......

    Tuesday, September 13, 2011 10:31 AM
  • I forgot to mention that the FBWF has to be enabled after the updates are applied to get the Open File Security Warning message.

    If you have the FBWF disable everything works just fine.

    Tuesday, September 13, 2011 2:00 PM
  • I finally found the responsible updates.

    Security Update for Windows Embedded Standard 7 (KB2559049): Internet Explorer 9 16-8-2011 2:00:00 Security Updates 21904815
    Security Update for Windows Embedded Standard 7 (KB2559049): Internet Explorer 8 16-8-2011 2:00:00 Security Updates 24879077

    After removing these the FBWF problem is solved. Although ignoring these updates might be a bad idea.
    Thank you for helping me out!

    Greetings

    • Edited by P.Bomers Wednesday, September 14, 2011 1:13 PM
    Wednesday, September 14, 2011 1:13 PM
  • I finally found the responsible updates.

    Security Update for Windows Embedded Standard 7 (KB2559049): Internet Explorer 9 16-8-2011 2:00:00 Security Updates 21904815
    Security Update for Windows Embedded Standard 7 (KB2559049): Internet Explorer 8 16-8-2011 2:00:00 Security Updates 24879077

    After removing these the FBWF problem is solved. Although ignoring these updates might be a bad idea.
    Thank you for helping me out!

    Greetings

    Nice job  P. Bomers

    I can confirm that there is an Issue with KB255904.

    I just imaged a new system, installed all updates except KB255904 and enabled the FBWF and everything worked fine.

    I then installed KB255904 and enabled the FBWF then I got the Open File Security Warning when opening programs, like IE, Paint, Calculator etc.

    Defiantly is something in that update that effects any other programs when using the FBWF.

     


    • Edited by SkyTech Wednesday, September 14, 2011 2:43 PM
    Wednesday, September 14, 2011 2:41 PM
  • you can add KB2586448 to the list of updates that trigger this problem.  I encountered the same issue with a large number of my machines.  After reading this post I went through all of my installed updates and after uninstalling KB2586448 I no longer had this issue.
    Tuesday, December 6, 2011 3:36 PM
  • in my research about this problem I also found another thread about this issue

    http://social.msdn.microsoft.com/Forums/en-US/quebeceefs/thread/54407ee2-3814-4ef3-aba0-f17cadda29d7

    According to it, Microsoft is aware of the issue and is working on a patch to fix it.  Hopefully that patch is released sooner than later

    Tuesday, December 6, 2011 3:38 PM
  • Thank you for the update cvg1wby!
    It's a really annoying issue so lets hope Microsoft will fix this soon!

    Thursday, December 29, 2011 10:57 AM
  • You can also add KB2618444 to the list as well.

    It seems all of these updates are related to IE8/IE9.

     

     

    Friday, January 13, 2012 5:24 PM
    • Marked as answer by P.Bomers Thursday, February 2, 2012 12:39 PM
    Tuesday, January 31, 2012 10:23 PM
  • Thank you!
    Thursday, February 2, 2012 12:39 PM
  • Wednesday, February 22, 2012 5:56 PM