locked
Secondary Search not working RRS feed

  • Question

  • Hi,

    We are using a search LightSwitch tool that we use to search tests.   We got it from a sample Lightswitch application.   In all the tool's pages, the secondary search does not work.(Please see attachment,  there are 2 datagrids.  Both have their own search box.   The search functionality for 'Suite-Test Script association' doesn't work.  If I do a search for any letter in test script dropdown box, the datagrid becomes blank.   The search for the first datagrid works.

    I notice this in debug window in Visual Studio after pressing search that in the Linq query that gets sent to our SQL database this piece:  "Where(obj => False)".   This piece of the Linq query only shows up when I'm trying to do a search.  How can I find out where this piece is coming from or any suggestions on why this issue is happening?  Thanks.

    Monday, November 21, 2016 9:29 PM

All replies

  • Hi ray500,

    This forum discuss Silverlight development issue in Visual Studio.

    Since your application is a LightSwitch application, I help you move this thread to LightSwitch forum to get a better help. Thanks for your understanding.

    Best Regards,
    Weiwei


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 22, 2016 8:13 AM
    Moderator
  • Thanks Weiwei.  I am confused.  Is this page you moved my question to? This forum's title is 'Visual Studio LightSwitch - General Questions'?   Or if not, can you give me a link to that Lightswitch forum that you moved my question to?  I can't find it anywhere else.

    Ray500

    Wednesday, November 30, 2016 6:41 PM