none
Hosted WSS 3.0 and SPD with SP2 - restore issue RRS feed

  • Question

  • Well,  I have been all over the web trying to find out why I can't restore a subsite after installing SPD with SP2.  I can find no answers.  The only tidbit of info might be that you must have Wss 3.0 with SP2 installed to get this to work.  I am aware of the previous restore problems with subsite over 25MB and that is why I upgraded to SPD with SP2.  Now the sites all appear to backup properly but when doing a restore I receive an erroe message stating the package file can't be read??? 

    As we know the restore reads each backed up .cmp file but after installing SPD with SP2 it seemd to error out after reading the first .cmp file.  I have 11 .cmp files that get backed up. 

    Has anyone had this issue?  Is there a fix?  Do you need WSS 3.0 with SP2 in order for the restore process to now work for subsites?
    Thursday, May 28, 2009 3:40 PM

Answers

  • Hi

     

    I don’t think WSS 3.0 without SP2 is the reason of restore failure and it’s difficult to say the cause of the restore problem. However, you can try to uninstall SPD SP2 and use the workaround in the article below to backup and restore sub sites in SPD.

    For the known issue that SPD cannot backup the Sites Greater than 24MB in size, you can find the workaround here:

    http://www.dotnetjunkies.com/WebLog/mwherman2000/archive/2007/07/26/271409.aspx

     

    If the problem still exists, please paste the detailed error message here and provide the steps you used to backup and restore the sub sites which help us to reproduce the problem, thanks.

     

    Hope this helps.

     

    Lu Zou

     

    • Marked as answer by Lu Zou-MSFT Friday, June 5, 2009 7:54 AM
    Monday, June 1, 2009 6:57 AM

All replies

  • WSS 3.0 SP2 changes a lot of things (including database schemas) so the host would need to have it upgraded also for your restore to work.

    The fix would be to ask the host to upgrade to WSS 3.0 SP2. Otherwise you would need to create a backup of the subsite with an older setup.


    That's SharePoint for you...
    • Edited by DueNorth Thursday, May 28, 2009 4:45 PM
    Thursday, May 28, 2009 4:43 PM
  • Thanks for the reply.  I'm trying to find out where the tech bulletin is that states WSS 3.0 with SP2 is required when using SPD with SP2 for subsite restores.  Any additional help is appreciated.  Right now I can't find a WSS Hosting provider to switch to that is running WSS 3.0 with SP2.
    Thursday, May 28, 2009 6:04 PM
  • Sorry, I miss read your post. I thought you had another environment with WSS 3.0 SP2 that you are trying to restore on a hosting site.

    I wouldn't think that SharePoint Designer with SP2 would affect the backup file. It depends though on how you are developing that subsite though. The two environment should be the same.
    That's SharePoint for you...
    Thursday, May 28, 2009 7:44 PM
  • Actually they are not and I did find a post that stated WSS 3.0 SP2 must be installed in order to use the new improved backup/restore in SPD SP2.  Maybe MS will respond accordingly.

    Thanks
    Thursday, May 28, 2009 7:58 PM
  • Hi

     

    I don’t think WSS 3.0 without SP2 is the reason of restore failure and it’s difficult to say the cause of the restore problem. However, you can try to uninstall SPD SP2 and use the workaround in the article below to backup and restore sub sites in SPD.

    For the known issue that SPD cannot backup the Sites Greater than 24MB in size, you can find the workaround here:

    http://www.dotnetjunkies.com/WebLog/mwherman2000/archive/2007/07/26/271409.aspx

     

    If the problem still exists, please paste the detailed error message here and provide the steps you used to backup and restore the sub sites which help us to reproduce the problem, thanks.

     

    Hope this helps.

     

    Lu Zou

     

    • Marked as answer by Lu Zou-MSFT Friday, June 5, 2009 7:54 AM
    Monday, June 1, 2009 6:57 AM