locked
Lightswitchbingmapscontrol not working in Windows Phone 8.1 (HTML) RRS feed

  • Question

  • This is strange but the BingMaps Control is not working under Windows Mobile 8.1.

    It says that the Control is not supported.

    Working in all other devices.

    Any thoughts?

    Sven


    Sven Elm



    • Edited by Sven Elm Thursday, September 25, 2014 5:35 PM
    Wednesday, September 24, 2014 7:18 AM

Answers

  • Solved!

    If you are running under SSL you have to put &s=1 in the call.

       

    <scripttype="text/javascript"charset="utf-8"


               

    src="https://ecn.dev.virtualearth.net/mapcontrol/mapcontrol.ashx?v=7.0&s=1&mkt=sv-SE"></script>

    //Sven


    Sven Elm

    • Marked as answer by Sven Elm Monday, September 29, 2014 7:50 AM
    Monday, September 29, 2014 7:50 AM

All replies

  • What do you mean by "Windows Mobile 8.1"?

    Do you mean "Windows 8.1" or "Windows Phone 8.1"?


    Simon Jones
    If you found this post helpful, please "Vote as Helpful". If it actually answered your question, please remember to "Mark as Answer". This will help other people find answers to their problems more quickly.

    Wednesday, September 24, 2014 9:39 AM
  • Sorry Windows phone 8.1

    Sven Elm

    Wednesday, September 24, 2014 9:41 AM
  • Sorry Windows phone 8.1

    Sven Elm


    Anyone?

    Sven Elm

    Thursday, September 25, 2014 3:45 PM
  • Sorry Windows phone 8.1


    Sven Elm


    Anyone?

    Sven Elm

    It says when debugging:

    Microsoft is not defined.

    And pointing to:

    Microsoft.Maps.loadModule(

    "Microsoft.Maps.Directions", { callback: $ });

    Only happens in Phone 8.1


    Sven Elm

    Thursday, September 25, 2014 5:35 PM
  • Sorry Windows phone 8.1


    Sven Elm


    Anyone?

    Sven Elm

    It says when debugging:

    Microsoft is not defined.

    And pointing to:

    Microsoft.Maps.loadModule(

    "Microsoft.Maps.Directions", { callback: $ });

    Only happens in Phone 8.1


    Sven Elm

    I think the module is not loaded yet.....

    0x800a1391 - JavaScript runtime error: 'Microsoft' is undefined


    Sven Elm



    • Edited by Sven Elm Thursday, September 25, 2014 5:37 PM
    Thursday, September 25, 2014 5:36 PM
  • Solved!

    If you are running under SSL you have to put &s=1 in the call.

       

    <scripttype="text/javascript"charset="utf-8"


               

    src="https://ecn.dev.virtualearth.net/mapcontrol/mapcontrol.ashx?v=7.0&s=1&mkt=sv-SE"></script>

    //Sven


    Sven Elm

    • Marked as answer by Sven Elm Monday, September 29, 2014 7:50 AM
    Monday, September 29, 2014 7:50 AM