none
Excel Addin RRS feed

  • Question

  • Hi,

    I have created Excel Addin using Excel-2003 template. When i am debugging the solution, addin gets displayed(gets loaded) in Excel. And it works as per my requirements.I have created Excel Addin setup.When i installed the setup Addin doesn't get displayed.

    LoadBehavior value changes from 3 to 2.

    I have added all required dlls in setup. But still facing the same issue.

    Please help

     

    Regard,

    Payal

    Sunday, January 1, 2012 6:47 AM

All replies

  • Hi Payal,

     

    Thanks for posting in the MSDN Forum.

     

    I would recommend you set a try…catch statement around your code in the ThisAddInStarup method. Let’s see whether you can get any exception in that method.

     

    Have a good day,

     

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us
    Tuesday, January 3, 2012 3:18 AM
    Moderator
  • Hi Tom,

    Thanks for the reply.

    Tried with try...catch block but its not throwing any exception.

    I have tried another method to create setup i.e. using Project -> Properties -> Publish -> Publish Now. When i install this setup it works fine for Excel 2007, Excel 2010 (32-bit, 64-bit). :-)

    Cant i create setup using Setup and Deployment , setup template?

     


    Payal B.
    Tuesday, January 3, 2012 4:37 AM
  • Hi Payal,


    My suggestion is go to event viewer and check the log for appropriate error.


    K K Sanghi
    Thursday, January 5, 2012 6:53 PM
  • Hi Payal_24,

     

    Sorry for later response.

     

    If you add-in is developed for 32-bit Office, it only works with 32-bit Office. And 64-bit add-in only works with 64-bit Office.

     

    I’m wondering whether you install 64-bit add-in for 32-bit Office or 32-bit add-in for 64-bit Office.

     

    Have a good day,

     

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us
    Thursday, January 12, 2012 7:34 AM
    Moderator
  • Hi Tom,

    I am debugging Excel addin code on 64bit machine where i have 64 bit excel in 'Any CPU' mode. While debugging addin gets loaded. I think there wont be any issue in my code.

    But couldn't deploy the build.

     


    Payal B.
    Friday, January 13, 2012 3:15 PM