locked
[WPSL] How to change the appx version number with the new system RRS feed

  • Question

  • I am trying to submit an update for the first time after the major change of the Dev Center.

    I keep getting the error: "The appx version number needs to be higher than previous version: 3.38.0.0" I have changed the version in Package.appxmanifest to 3.40.0.0.  This is what I have been doing all the time. The new system does not like it.  Could anyone offer a tip on this?

    I opened the package MyApp_Release_AnyCPU.xap and took a peek at AppxManifest.xml, and found the the following:

    <Identity ... Version="3.40.0.0" ProcessorArchitecture="neutral" />

    Why is 3.40.0.0 regarded as a number lower than 3.38.0.0?


    Hong



    Friday, July 17, 2015 4:01 AM

Answers

  • For some reason the new dashboard reads the version number from the WMAppManifest.xml instead of AppxManifest.xml, Updating the version number in the WMAppManifest.xml should help,

    I think this is a minor bug which will be fixed soon

    • Proposed as answer by Tareq Ateik Thursday, July 23, 2015 1:20 PM
    • Marked as answer by Hong (MA, USA) Thursday, July 23, 2015 4:05 PM
    Thursday, July 23, 2015 12:56 PM

All replies

  • For some reason the new dashboard reads the version number from the WMAppManifest.xml instead of AppxManifest.xml, Updating the version number in the WMAppManifest.xml should help,

    I think this is a minor bug which will be fixed soon

    • Proposed as answer by Tareq Ateik Thursday, July 23, 2015 1:20 PM
    • Marked as answer by Hong (MA, USA) Thursday, July 23, 2015 4:05 PM
    Thursday, July 23, 2015 12:56 PM
  • Hi.

    i have the same problem.but in my project SL 8.1 version number  is in  WMAppManifest.xml .But i also get the same error.How to solve this

    Saturday, August 22, 2015 5:17 AM