locked
GetAuthenticationInfo error - Yann Duran - Lightswitch 2012 RRS feed

  • Question

  • Hi everyone, especially Yann Duran,

    I have a problem with any Silverlight application I made with Visual Studio 2012 : after publishing the app for web client, and then I try to connect to it I receive that error : "Load operation failed for query 'GetAuthenticationInfo'. The remote server returned an error: NotFound."

    This problem is weird because every type of authentication that I use (no authentication, Windows authentication or forms authentication) I always get this error.

    Other thing, when I publish on my local IIS, I have no folder named ServerGenerated or ClientGenerated. And some folders are missing in C:\inetpub\wwwroot\myApp\DesktopClient\Web

    Maybe there is a link with the initial error...

    Can you help me to solve this problem?
    • Edited by Rom's Monday, June 10, 2013 7:25 PM Quote Yann Duran
    Monday, June 10, 2013 2:58 PM

Answers

  • Okay, I searched again this afternoon on solution and here is more precisions about it :

    • Yesterday, I remember that installed Visual Studio SDK and re-install .NET Framework 4.5
    • Also, I activated all services of ".NET Framework 4.5 Advanced  services" in "Turn Windows features on or off"
    • The problem was that .svc files were not mapped with WCF (check it on "Handler mappings" from IIS)

    --> Activating all services of ".NET Framework 4.5 Advanced services" in "Turn Windows features on or off" solves the problem.

    • Marked as answer by Rom's Wednesday, June 12, 2013 3:14 PM
    Wednesday, June 12, 2013 3:14 PM

All replies

  • I have had some similar errors, and you say you have tried everything, so you may have tried much of this... but here is some guesses:

    1. Do a project 'Clean' (right click on project and click clean)
    2. Then an unload of the project
    3. Then reload
    4. Rebuild the project
    5. Other similar 'cleanup' tasks such as closing and re-opening Visual Studio too.
    6. When you publish Make sure the Checkbox is NOT checked for 'IIS Server has the Deployment Prerequisites Installed' (not sure this would be a problem, but just in case)
    7. When you publish make sure you answer YES to 'Creating' the administrative account (You didn't specify what type of authentication you are using:  I use Windows Authentication)
    8. Try to get YANN's attention, he could probably answer this much better than I!

    Would someone please turn on the LIGHT?

    Monday, June 10, 2013 4:50 PM
  • I already tried all you said...

    This problem is weird because every type of authentication that I use (no authentication, Windows authentication or forms authentication) I always get this error.

    Other thing, when I publish on my local IIS, I have no folder named ServerGenerated or ClientGenerated. And some folders are missing in C:\inetpub\wwwroot\myApp\DesktopClient\Web

    Maybe there is a link with the initial error...

    Monday, June 10, 2013 7:04 PM
  • Oh, well you didn't try contacting Yann...! (grin)

    Good luck!


    Would someone please turn on the LIGHT?

    Monday, June 10, 2013 7:07 PM
  • Yeah, in my opinion, based on all of the searching I have done for help online, besides Beth, there are two in the community that have been invaluable to get up-to-speed on LightSwitch:

    Yann and Mike Washington.

    Yann is primarily an in-the-know Silverlight Client expert.  Also, as you have seen, Michael is the HTML Client Guy.

    Of very high Honorable mention is Mr Yossu because of his extensions he has offered for FREE that I have found daily use in the Apps I'm working on.

    Good luck, and my guess is that Yann will likely be chiming in soon!

    Take care!


    Would someone please turn on the LIGHT?

    Monday, June 10, 2013 7:55 PM
  • Ding dong! :-P (that's a chime btw, for anyone who didn't realise)

    Thanks for the very kind words Joe.

    That particular error can be caused by so many different things, it's hard to say "do this" & everything's fixed. It can often be very complicated to track it down.

    In addition to Joe's suggestions, have you double checked that you've supplied the correct server/username/password combination in the Publish Wizard for the database? Check that you can use those details to connect to the database using SSMS (SQL Server Management Studio), if you have it installed.

    Being a web application makes it even harder for me to say exactly what your problem could be (I only do desktop applications), but this link is the best one I know of that will walk you through tracking down problems in web applications.

    Diagnosing Problems in a Deployed 3-Tier LightSwitch Application

    "Other thing, when I publish on my local IIS, I have no folder named ServerGenerated or ClientGenerated"

    Only LS V1 had the two "generated" folders. LS V2 did away with them. If you upgraded a project from V1 to V2, the folders remain in the LS project, but they're not used, & can be safely deleted.


    Yann Duran
         - Co-Author of Pro Visual Studio LightSwitch 2011
         - Author of the  LightSwitch Central Blog

    FREE Download: Luminous Tools for LightSwitch
    (a Visual Studio productivity extension for LightSwitch)
     
    Click Mark as Answer, if someone's reply answers your question
    Click  Vote as Helpful, if someone's reply is helpful
     
    By doing this you'll help everyone find answers faster.

    • Proposed as answer by babloo1436 Tuesday, June 11, 2013 4:51 PM
    Tuesday, June 11, 2013 5:39 AM
    Moderator
  • Hi Yann

    I can connect to the database in SQL Server Management Studio with the username/password I used in Publish Wizard.

    I followed the link you posted and I get the 404 error (not the 500 as the "Diagnosing Problems in a Deployed 3-Tier LightSwitch Application" page) when I try what they say. I found that "Microsoft-LightSwitch-Security-ServerGenerated-Implementation-AuthenticationService.svc\binary\GetAuthenticationInfo" is missing in my Web folder of my app.

    An other precision, when I add a HTML Client to my app and then I publish it, when I launch the app with the HTML client, I have 4 errors 404 in Fiddler, 4 files are missing (again) :

    • HTMLClient\Content\Resources\client.lang-FR.resjson
    • HTMLClient\Content\Resources\service.lang-FR.resjson
    • Microsoft.LightSwitch.SecurityData.svc\GetAuthenticationType
    • ApplicationData.svc\ContactSet
    Tuesday, June 11, 2013 10:09 AM
  • I wish I could help you more, but unfortunately I don't have any experience with the HTML client yet.

    Hopefully Michael (I'll try to ping him for you), or Huy from the LightSwitch team, will see this thread & have a better idea what to do.


    Yann Duran
         - Co-Author of Pro Visual Studio LightSwitch 2011
         - Author of the  LightSwitch Central Blog

    FREE Download: Luminous Tools for LightSwitch
    (a Visual Studio productivity extension for LightSwitch)
     
    Click Mark as Answer, if someone's reply answers your question
    Click  Vote as Helpful, if someone's reply is helpful
     
    By doing this you'll help everyone find answers faster.

    Tuesday, June 11, 2013 1:45 PM
    Moderator
  • Thank you so much Yann. This error is poison me and I search since few days to find... nothing...

    Some people had the same error but they solved the problem easily. In my company we are 2 in this case and we have the next configuration :

    • Windows 8 x64
    • IIS 8
    • SQL Server 2008 R2
    • Visual Studio 2012 Update 2

    Hope there is a way to fix that.

    Tuesday, June 11, 2013 2:27 PM
  • If GetAuthenticationType is not there then your application will not work. It is a required file. To see all the files that load for a normal application, see: How Does A LightSwitch HTML Client Application Work?

    If it is not there, then the publishing wizard is not working correctly. I would re-install Visual Studio.


    The Visual Studio LightSwitch Marketplace

    http://LightSwitchHelpWebsite.com

    Tuesday, June 11, 2013 4:53 PM
  • I will try to re-install Visual Studio but I don't think that will solve the problem because we are 2 persons on 2 different machines (but same configuration) and we have the same problem.

    I will try tomorrow and I'll tell you.

    Tuesday, June 11, 2013 6:34 PM
  • Hi everybody

    Big surprise this morning : everything works very well! I have done NOTHING and it works.

    More details :

    • Yesterday before turn off my computer, there was always all problems above
    • This morning, just after start my computer, I launch a Silverlight web app and a HTML app, both work
    • I don't install or re-install anything, there was no update from my computer

    God or magic passed on the computer...

    Normally, it's solved. However, thanks to everyone for your help.

    • Marked as answer by Rom's Wednesday, June 12, 2013 11:34 AM
    • Unmarked as answer by Rom's Wednesday, June 12, 2013 3:14 PM
    • Proposed as answer by Yann DuranModerator Friday, June 14, 2013 5:18 AM
    • Unproposed as answer by Yann DuranModerator Friday, June 14, 2013 5:19 AM
    Wednesday, June 12, 2013 11:33 AM
  • Well, glad it worked for you.  It sounds SIMILAR to a problem I have had when running in debug mode (so cannot be the same problem as yours, but similar symptoms).

    What happens is it errors, and the way I have to clear it is to right-click and 'Stop' the localhost instance (as shown), then try again.

    So what I'm suggesting is that this may be because some resource finally got unloaded on your server and reloaded, therefore using the good build, etc.


    Would someone please turn on the LIGHT?

    Wednesday, June 12, 2013 1:34 PM
  • Okay, I searched again this afternoon on solution and here is more precisions about it :

    • Yesterday, I remember that installed Visual Studio SDK and re-install .NET Framework 4.5
    • Also, I activated all services of ".NET Framework 4.5 Advanced  services" in "Turn Windows features on or off"
    • The problem was that .svc files were not mapped with WCF (check it on "Handler mappings" from IIS)

    --> Activating all services of ".NET Framework 4.5 Advanced services" in "Turn Windows features on or off" solves the problem.

    • Marked as answer by Rom's Wednesday, June 12, 2013 3:14 PM
    Wednesday, June 12, 2013 3:14 PM
  • Oh, I remember doing some of those things, now that you mention it, in particular the .Net stuff.  Again, glad you figured it out!

    Would someone please turn on the LIGHT?

    Wednesday, June 12, 2013 3:17 PM
  • Thank you JoeB_LS103 :-)
    Thursday, June 13, 2013 7:09 AM
  • You are Welcome!  Good luck!

    Would someone please turn on the LIGHT?

    Thursday, June 13, 2013 7:26 PM