none
printer properties installation problem RRS feed

  • Question

  • Hello,

     I'm busy creating a virtual printer driver (type 3, XPSDrv based, Visual Studio 2013, WDK 8.1). As part of the testing I try it out on a Windows 7 x64 machine. The printer driver installs OK, but since this week I can no longer get to "Printer Properties" (right-click on the printer icon) without getting first a "The 'XXX' printer driver is not installed on this computer. Some printer properties will not be accessible unless you install the printer driver. Do you want to install the printer driver now? [Yes] [No]. Selecting Yes will bring up a wizard, but still not success. Selecting No will bring up the Printer Properties dialog box.

    I have tried deleting the printer driver and installing an older printer driver that did work. However the older printer driver keeps on failing as well. Note: I made sure to reboot between removing the printer driver and using the older printer driver. I first thought it was caused by perhaps changes I made to the GPD, but that does not appear to be the case. Are there hidden/secret logging to see where this all goes wrong?

    Thanks in advance

    Theo
    Wednesday, September 3, 2014 1:22 PM