none
SharePoint Internet site redirection RRS feed

  • Question

  • Hi,

    My client has an internet facing SharePoint site e.g. www.abc.com and we have set up the DNS server with a local domain abc.co.uk for the UK site pointing to http://www.abc.com/UK/Pages/default.aspx (this works fine)

    At this point we are able to browse to www.abc.co.uk which is redirecting to http://www.abc.com/UK/Pages/default.aspx

    I have verified that we are able to browse the sub-site for example: http://www.abc.com/UK/certification/IT/Pages/default.aspx anonymously. However when we visit the page: http://www.abc.co.uk/certification/IT/Pages/default.aspx  it's prompting for ID and password.

    Cancelling the log-in prompt would give an error:
    XML Parsing Error: no element found
    Location: http://www.abc.co.uk/certification/IT/Pages/default.aspx
    Line Number 1, Column 1:

    I don't understand why the root site is redirecting and the sub-site is not, considering it is a branch of the root site. Any help will be much appreciated.

    Regards,

    Sabs


    Thanks, Sabs Banerjee



    • Edited by Sabsync Thursday, September 20, 2012 3:17 PM
    Thursday, September 20, 2012 3:15 PM

Answers

  • Hi Sabs,

    Check the following things.

    First, the url of the sub site is independent, you should also set DNS server redirect for sub site.

    Second, the redirected url should be added to Alternate access mapping.

    Regards,

    Kelly Chen

    Friday, September 21, 2012 9:53 AM
    Moderator