locked
Passing multivalue parameter to a subreport RRS feed

  • Question

  • In RS 2005 I have a multivalue parameter.
    When I click to the related subreport I cannot see any values.
    I have use join(Parameters!MValue, ",") as expression.
    How can I solve this issue? Thanks
    Thursday, March 12, 2009 8:39 PM

Answers

  • I have solved by using SPLIT(JOIN(Parameters!Mvalue.Value,","),",") as parameter for the jump action.
    In this way, I can pass the selected values as an array.
    Thanks
    • Marked as answer by Raymond-Lee Tuesday, March 17, 2009 5:16 AM
    Saturday, March 14, 2009 9:48 PM

All replies

  • Hi pscora,

    Your don't need to use join(Parameters!MValue, ",") when drilling down to another (child) report that has a multivalue parameter.
    just 
    =Parameters!Mvalue.Value in the expression box  if you get (0) on the end this will only use the 1st value in the array (0)

    To help debugging remove the child report ,parameter selection, built on a query and see what you are passing is suspect you are passing  "value1,value2....." in one line

    SSRS required the multivaluse are passed
    value1
    value2
    ...
    ..
    .
    But you need to click on the parameter to see the differences


    Hope this helps
    Thursday, March 12, 2009 9:32 PM
  • I need to pass the selected values of the multivalue parameter of the parent report.

    When I use the join, I get the selected values, but these are organized into a string as "value1, value2 ...";

    when I use Parameters!Mvalue.Value all values are passed as a "value1, value2, value3, value4" string (fe the Mvalue has 4 values) and I don't want this behaviour.
    When I indicate the report for the jump, I must specify for the mvalue parameter an array with only the selected values: how can I do it?

    Thanks.

    Thursday, March 12, 2009 11:13 PM
  • I have solved by using SPLIT(JOIN(Parameters!Mvalue.Value,","),",") as parameter for the jump action.
    In this way, I can pass the selected values as an array.
    Thanks
    • Marked as answer by Raymond-Lee Tuesday, March 17, 2009 5:16 AM
    Saturday, March 14, 2009 9:48 PM