none
office 365 / activesync 16 - error forwarding meeting RRS feed

  • Question

  • My ActiveSync client which consistently is able to forward meeting requests on ActiveSync version 12.1 through 14.1 is failing to forward the meeting. The ActiveSync smart forward operation is failing with a wbxml status 120 which corresponds to:

    120

    MailSubmissionFailed

    The server failed to submit the message for delivery.

    Supported by: 14.0, 14.1, 16.0

    This is the same result on exchange 2013 as well as on Outlook 365.

    To reproduce this I open an event that I created in my calendar, then forward the meeting to a new recipient.

    The message looks like this - note that the boundary names and email address has been redacted.

    Date: Mon, 02 Nov 2015 17:30:52 +0100
    Subject: Fwd: test 
    Priority: normal
    X-Priority: normal
    References: 1:12
    From: testuser1@xxx.onmicrosoft.com
    To: TestUser Four <testuser4@xxx.onmicrosoft.com>
    MIME-Version: 1.0
    Content-Type: multipart/alternative;boundary="_com.xxx.email_ADF80688-CF87-495F-863C-CA3E8F7D6938"

    --_com.xxx.email_ADF80688-CF87-495F-863C-CA3E8F7D6938
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: base64

    PGhyPjxkaXYgc3R5bGU9ImZvbnQtZmFtaWx5OkNhbGlicmksSGVsdmV0aWNhTmV1ZSxzYW5zLXNlcmlmOyIgZGlyPSJhdXRvIj48YnI+PGI+RnJvbTo8L2I+IHRlc3R1c2VyMUB3b3J4bWFpbC5vbm1pY3Jvc29mdC5jb208YnI+PGI+VG86PC9iPiBUZXN0VXNlciBUd28gJmx0O3Rlc3R1c2VyMkB3b3J4bWFpbC5vbm1pY3Jvc29mdC5jb20mZ3Q7PGJyPjxiPlN1YmplY3Q6PC9iPiB0ZXN0IDxicj48L2Rpdj4K
    --_com.xxx.email_ADF80688-CF87-495F-863C-CA3E8F7D6938
    Content-Type: text/html; charset=utf-8
    Content-Transfer-Encoding: base64

    PCFkb2N0eXBlIGh0bWw+PGh0bWw+PGhlYWQ+PG1ldGEgY2hhcnNldD0idXRmLTgiPjwvaGVhZD48Ym9keT48ZGl2IHN0eWxlPSJmb250LWZhbWlseTpDYWxpYnJpLEhlbHZldGljYU5ldWUsc2Fucy1zZXJpZjsiPjxkaXYgZGlyPSJhdXRvIj4KPGRpdiBkaXI9ImF1dG8iPjxicj48ZGl2IGRpcj0iYXV0byI+PGJyPjwvZGl2PjwvZGl2PjwvZGl2PjwvZGl2PjwvYm9keT48L2h0bWw+PGhyPjxkaXYgc3R5bGU9ImZvbnQtZmFtaWx5OkNhbGlicmksSGVsdmV0aWNhTmV1ZSxzYW5zLXNlcmlmOyIgZGlyPSJhdXRvIj48YnI+PGI+RnJvbTo8L2I+IHRlc3R1c2VyMUB3b3J4bWFpbC5vbm1pY3Jvc29mdC5jb208YnI+PGI+VG86PC9iPiBUZXN0VXNlciBUd28gJmx0O3Rlc3R1c2VyMkB3b3J4bWFpbC5vbm1pY3Jvc29mdC5jb20mZ3Q7PGJyPjxiPlN1YmplY3Q6PC9iPiB0ZXN0IDxicj48L2Rpdj48YnI+
    --_com.xxx.email_ADF80688-CF87-495F-863C-CA3E8F7D6938--

    Looking at the activesync logs I can see that this is the server error


    RequestHeader : 
    POST /Microsoft-Server-ActiveSync/Proxy/default.eas?Cmd=SmartForward&User=testuser1%40worxmail.onmicrosoft.com&DeviceId=FE718E54440948DBBF104F79D70D0924&DeviceType=iPhone HTTP/1.1
    Connection: close
    Content-Length: 1646
    Content-Type: application/vnd.ms-sync.wbxml
    Accept-Encoding: gzip
    Authorization: ********
    Cookie: ClientId=4WWP3BL5HUISTFPJYOEPEW
    Host: outlook.office365.com:443
    User-Agent: WorxMail/10.4-main iPhone/9.1
    X-MS-PolicyKey: 1903012562
    MS-ASProtocolVersion: 14.1
    X-MSExchangeActivityCtx: V=1.0.0.0;Id=69feca70-0f79-4fae-8e70-fa9aa376a635;C=;P=
    X-OriginalRequestHost: outlook.office365.com
    X-OriginalRequestHostSchemePort: 443:https:outlook.office365.com
    X-ProxyTargetServer: AM4PR08MB0785.eurprd08.prod.outlook.com
    X-ProxyTargetPort: 444
    X-ProxyTargetServerVersion: 1942061368
    X-DatabaseGuid: 23517351-04e1-4c17-b39e-05e80d564fd5
    X-RoutingEntry: LiveIdMemberName:testuser1%40worxmail.onmicrosoft.com%3B=DatabaseGuid:23517351-04e1-4c17-b39e-05e80d564fd5%40worxmail.onmicrosoft.com%40eurprd08.prod.outlook.com%400@130909584910215757,CafeArrayDbGuid:23517351-04e1-4c17-b39e-05e80d564fd5%40worxmail.onmicrosoft.com%40eurprd08.prod.outlook.com=CafeArray:-1%2C-1%2C-1%2C-1+True@130909584910215757,DatabaseGuid:23517351-04e1-4c17-b39e-05e80d564fd5%40worxmail.onmicrosoft.com%40eurprd08.prod.outlook.com=Server:AM4PR08MB0785.eurprd08.prod.outlook.com+1942061368@635817245012909679
    X-GCC-PROXYINFO: ALHCYE5RBwHD/rQ1ne9I1dXfVk92ffFqsqIZeFQc1gewWQ0/+X3EKBIFHPTCpqpPHk1quwyq49II,109.192.63.117,10.242.16.31
    X-SourceCafeServer: AM3PR04CA0031.EURPRD04.PROD.OUTLOOK.COM
    msExchProxyUri: https://outlook.office365.com/Microsoft-Server-ActiveSync?Cmd=SmartForward&User=testuser1%40worxmail.onmicrosoft.com&DeviceId=FE718E54440948DBBF104F79D70D0924&DeviceType=iPhone
    X-IsFromCafe: 1
    X-CafeProxyHandler: NativeHttpProxy
    X-Forwarded-For: 109.192.63.117
    X-Forwarded-Port: 23796
    X-MS-EdgeIP: 
    X-WLID-MemberName: testuser1@worxmail.onmicrosoft.com
    RPSMemberName: testuser1@worxmail.onmicrosoft.com


    RequestBody : 
    <?xml version="1.0" encoding="utf-8" ?>
    <SmartForward xmlns="ComposeMail:">
    <ClientId>2795962128C947ED9CBEFED4FFFB4968</ClientId>
    <SaveInSentItems/>
    <Source>
    <ItemId>1:12</ItemId>
    <FolderId>1</FolderId>
    </Source>
    <Mime>[Mime Removed] BytesCount = 1594</Mime>
    </SmartForward>

    Command_WorkerThread_Exception : 
    --- Exception start ---
    Exception type: Microsoft.Exchange.AirSync.AirSyncPermanentException
    Exception message: 
    Exception level: 0
    HttpStatusCode: InternalServerError
    AirSyncStatusCode: MailSubmissionFailed
    ProtocolLoggerString: 
    XmlResponse: 
    [No XmlResponse]
    Exception stack trace:    at Microsoft.Exchange.AirSync.SendMailBase.SendMessage(MessageItem sendMessage)
       at Microsoft.Exchange.AirSync.SmartForwardCommand.ForwardUsingXso(StoreObjectId smartId)
       at Microsoft.Exchange.AirSync.Command.WorkerThread()
    Inner exception follows...
    Exception type: Microsoft.Exchange.Data.Storage.SendAsDeniedException
    Exception message: Cannot submit message.
    Exception level: 1
    Exception stack trace:    at Microsoft.Exchange.Data.Storage.CoreItem.Submit(SubmitMessageFlags submitFlags, Boolean performAntiSpamCheck)
       at Microsoft.Exchange.Data.Storage.MessageItem.InternalSend(StoreObjectId saveSentMessageFolder, SubmitMessageFlags submitFlags, Boolean doNotMove, Boolean performAntispamCheck)
       at Microsoft.Exchange.Data.Storage.MessageItem.Send(SubmitMessageFlags submitFlags)
       at Microsoft.Exchange.AirSync.SendMailBase.SendMessage(MessageItem sendMessage)
    Inner exception follows...
    Exception type: Microsoft.Mapi.MapiExceptionSendAsDenied
    Exception message: MapiExceptionSendAsDenied: Unable to submit message. (hr=0x80070005, ec=1244)
    Diagnostic context:
        Lid: 55847   EMSMDBPOOL.EcPoolSessionDoRpc called [length=124]
        Lid: 43559   EMSMDBPOOL.EcPoolSessionDoRpc returned [ec=0x0][length=328][latency=31]
        Lid: 52176   ClientVersion: 15.1.312.20
        Lid: 50032   ServerVersion: 15.1.312.6020
        Lid: 35180  
        Lid: 23226   --- ROP Parse Start ---
        Lid: 27962   ROP: ropSubmitMessage [50]
        Lid: 17082   ROP Error: 0x4DC     
        Lid: 27745  
        Lid: 21921   StoreEc: 0x4DC     
        Lid: 27962   ROP: ropExtendedError [250]
        Lid: 1494    ---- Remote Context Beg ----
        Lid: 37692  
        Lid: 44092  
        Lid: 64952   StoreEc: 0x3EB     
        Lid: 40748   qdwParam: 0xF01000000000001 
        Lid: 57132   qdwParam: 0xE012751C00000001
        Lid: 36423   dwParam: 0x0        Msg: testuser1@worxmail.onmicrosoft.com
        Lid: 42092   StoreEc: 0x4DC     
        Lid: 58476  
        Lid: 10786   dwParam: 0x0        Msg: 15.01.0312.001:AM4PR08MB0785
        Lid: 1750    ---- Remote Context End ----
        Lid: 26849  
        Lid: 21817   ROP Failure: 0x4DC     
        Lid: 60547   StoreEc: 0x4DC     
        Lid: 21966  
        Lid: 30158   StoreEc: 0x4DC     
    Exception level: 2
    Exception stack trace:    at Microsoft.Mapi.MapiExceptionHelper.InternalThrowIfErrorOrWarning(String message, Int32 hresult, Boolean allowWarnings, Int32 ec, DiagnosticContext diagCtx, Exception innerException)
       at Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, IExInterface iUnknown, Exception innerException)
       at Microsoft.Mapi.MapiMessage.SubmitMessageEx(SubmitMessageExFlags submitMessageExFlags)
       at Microsoft.Exchange.Data.Storage.CoreItem.Submit(SubmitMessageFlags submitFlags, Boolean performAntiSpamCheck)
    --- Exception end ---

    AccessState : 
    Allowed

    AccessStateReason : 
    Global

    ResponseHeader : 
    HTTP/1.1 200 OK


    ResponseBody : 
    <?xml version="1.0" encoding="utf-8" ?>
    <SmartForward xmlns="ComposeMail:">
    <Status>120</Status>
    </SmartForward>

    Monday, November 2, 2015 5:14 PM

All replies

  • Lee,
    This forum handles requests related to Open Specifications documentation issues. The Open Specifications can be found at: http://msdn2.microsoft.com/en-us/library/cc203350.aspx. Your question does not appear to be related to the Open Specifications documentation set.

    Based on the description of your inquiry, I suggest you try the following forums to get assistance: 
    http://answers.microsoft.com/en-us/office/forum/office_365hp-outlook-os_device_win10desk?sort=lastreplydate&dir=desc&tab=threads&status=all
    http://answers.microsoft.com/en-us/office/forum/office_2016-outlook-os_device_win10desk?tab=Threads

    If you were implementing ActiveSync protocol on the client side, please let us know and we will review.
    [MS-ASCMD]: Exchange ActiveSync: Command Reference Protocol
    https://msdn.microsoft.com/en-us/library/dd299441.aspx

    Thanks,
    Edgar

    Monday, November 2, 2015 9:39 PM
    Moderator
  • Hi Edgar 

    I am implementing a commercial client side activesync client. I've posted a number of other questions in these forums here earlier - in particular https://social.msdn.microsoft.com/Forums/en-US/2771c82f-b447-4195-8de3-bad2e046e133/http-500-and-lost-data-with-activesync?forum=os_exchangeprotocols#2771c82f-b447-4195-8de3-bad2e046e133 which was related to a similar activesync protocol question.

    This question relates to the behaviour of the activesync protocol on activesync 16 and my understanding was this is the place that those questions can be resolved.

    I'll post the same question on the forum you suggested though.


    Lee

    Monday, November 2, 2015 10:04 PM
  • Hi Lee,

    One of our engineers will review this and follow up with you.

    Thanks,

    Edgar

    Tuesday, November 3, 2015 3:32 AM
    Moderator
  • Hello Lee :

    I'll be assisting you further. Can you please share exchange on-prem logs by sending as an attachment to email address : dochelp at Microsoft.com for further analysis ?

    Regards


    Tarun Chopra | Escalation Engineer | Open Specifications Support Team

    Tuesday, November 3, 2015 6:33 AM
  • Hello Lee :

    Dropping a note to acknowledge that we have received your log files.

    We will continue to troubleshoot the issue through dochelp and post of our findings on this thread once issue is resolved.

    Regards


    Tarun Chopra | Escalation Engineer | Open Specifications Support Team

    Tuesday, November 3, 2015 10:57 PM
  • We worked with Lee offline and suggested to implement the AccountId Element in the app's request to resolve the issue.

    2.2.3.3.1 AccountId (SendMail, SmartForward, SmartReply)
    https://msdn.microsoft.com/en-us/library/gg672075(v=exchg.80).aspx


    Tarun Chopra | Escalation Engineer | Open Specifications Support Team

    Tuesday, January 5, 2016 9:49 PM
  • Hi Tarun Chopra, I am running into a similar issue. Do you know if including the AccountId resolved the issue? If not, do you have any other suggestions?
    Monday, October 24, 2016 2:29 PM
  • Hi IanRagsdale,

    Thank you for your question.  An engineer from the protocols team will contact you soon.


    Bryan S. Burgin Senior Escalation Engineer Microsoft Protocol Open Specifications Team

    Monday, October 24, 2016 3:37 PM
    Moderator
  • Hello Ian:

     

    Following were the suggestions shared,however, we are not sure if it resolved the issue since Lee added it to the backlog:

     

    1. Specify following settings command settings:PrimarySmtpAddress (https://msdn.microsoft.com/en-us/library/gg663418(v=exchg.80).aspx )

    2. Send AccountId  element in the request (2.2.3.3.1 AccountId (SendMail, SmartForward, SmartReply)) https://msdn.microsoft.com/en-us/library/gg672075(v=exchg.80).aspx  

     

    If AccountID is not specified and settings:PrimarySmtpAddress is not configured, SendAsDenied exception will be raised.

     

    Thanks


    Tarun Chopra | Escalation Engineer | Open Specifications Support Team

    Tuesday, October 25, 2016 3:53 PM