none
Error : DEP0001 : Unexpected Error: Package type matching the cpu 'X86'

    Question

  • I get Error : DEP0001 : Unexpected Error: Package type matching the cpu 'X86' of the device not found in package 'EB22551A-7F66-465F-B53F-E5ABA0C0574E', trying to run any universal app in emulator.

    All the emulators give the same result regardless of emulator selection or which solution platform is selected. App works fine when local machine is selected.

    Any suggestions as to the resolution of this error?

    Chris

    p.s. this question has been asked before by someone else, but the marked "Answer" was just a series of further questions, not an answer; so I'm trying again


    • Edited by ChrisJiggs Wednesday, April 06, 2016 3:22 PM clarification
    Wednesday, April 06, 2016 3:21 PM

All replies

  • Hi ChrisJiggs,

    Thank you for your post.

    For this issue, since you couldn’t run any universal app in emulator when matching the CPUx86,
    How about running the app under ARM mode?

    Suppose it still doesn’t work when you choose ARM, I suspect that the emulator is broken, please delete the emulator in the Hyper-V first,

    Then create a new emulator and enable Hyper-V in it to see if it works.

    Refer to:

    https://msdn.microsoft.com/en-us/library/windows/apps/jj863509%28v=vs.105%29.aspx?f=255&MSPPError=-2147217396

    Besides, if you still have question about this, please see the following document about Troubleshooting the Windows Phone 8 Emulator:

    https://msdn.microsoft.com/en-us/library/windows/apps/jj681694%28v=vs.105%29.aspx?f=255&MSPPError=-2147217396

    Best Regards,

    Lake Xiao

    Thursday, April 07, 2016 8:27 AM
    Moderator
  • Hi,

    Thanks for the reply, unfortunately this hasn't solved the problem. I have not been able to deploy the universal app to an emulator in any configuration (x64, x86, ARM). x64 and x32 always return the same error message (including x64 complaining about being unable to find x86). I don't have the option of running on emulator when selecting ARM. The emulator does fire up correctly and I can interact with the pre-installed applications and running OS but VS fails to deploy application. Emulator I'm trying to use is "Mobile Emulator 10.0.10240.0 1080p 6 inch 2GB"

    I have tried the following without any luck:

    1. Deleted all entries in Hyper-V to allow them to be recreated when required.

    2. Uninstalled the emulator packages and re-installed.

    3. Worked through all the checks listed in your two links above. 

    4. The machine has been re-booted multiple times during this process.

    None of the above changed the error code. The only other comments I have found online about this problem talk about uninstalling VS2015 Pro and re-installing. If really don't want to go down that route unless all other options fail.

    For clarification, the app that I am trying to run is straight from Visual Studios template, without any changes from the template generated code.

    Any further thoughts on what this might be?

    Thanks

    Chris

    Thursday, April 07, 2016 12:09 PM
  • Hi Chris,

    Thanks for your response.

    From your description, it seems that your emulator is ok, but when you try to deploy the app on hyper-V emulator with VS, some packages are failed to load, so the problem is pending on VS itself,

    Please try to repair your VS with a good iso, and repair all the windows SDK, so that the packages could load properly.

    If the above still doesn't help, I need you installation log file to troubleshoot this issue,

    please use http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to  https://onedrive.live.com/and share the link here.


    Best Regards,

    Lake Xiao


    Friday, April 08, 2016 1:51 AM
    Moderator