locked
InfoPath & SharePoint 2007 Form Library - multiple fields with same name, but different data types RRS feed

  • Question

  • Hello

    we have a 2007 SharePoint Enterprise server.  A couple of years ago a developer automated a request process with forms and workflow.

    The InfoPath template for the form has  a dozen drop down lists on it.  Each of these DDLs is pulling data from an SP list. 

    When looking at the Settings for the SharePoint Form Library each of these drop down fields is listed twice.  One with a data type of Single Line of Text and one with a type of Lookup.  The Text field contains the ID and the Lookup field contains the Title.

    There are a couple dozen views for this Library.  They are used to display the Requests based upon who it is assigned to, or what stage of the process it is in.  The condition for the viws is based on the ID value, but the display is the Title value.

    We are in the process of trying to move all of this to a 2010 Standard (long story we dont have 2010 enterprise licenses).

    I have tried to use MetaViz to move the Library.  When it comes over, when I look at any of the views, all of those lookup/id fields are empty.

    If I open the forms, they all have the data in them, and look correct, but when looking at the 'data' from within the SP list, the fields are all empty.

    I have tried re-linking them.

    When a new form is created, one of the things it does is to send out a notice, using workflow.  The email is sent out but all of the fields that normally apear in the message are blank.

    All of the columns in the views are blank, but opening up the form all of the data is there.

    Any ideas?



    • Edited by PeterMHope Wednesday, August 22, 2012 9:23 PM
    Wednesday, August 22, 2012 8:19 PM